summaryrefslogtreecommitdiffstats
path: root/bsp/meta-ti/recipes-bsp/osal/osal_git.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /bsp/meta-ti/recipes-bsp/osal/osal_git.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'bsp/meta-ti/recipes-bsp/osal/osal_git.bb')
-rw-r--r--bsp/meta-ti/recipes-bsp/osal/osal_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/bsp/meta-ti/recipes-bsp/osal/osal_git.bb b/bsp/meta-ti/recipes-bsp/osal/osal_git.bb
new file mode 100644
index 00000000..8f589376
--- /dev/null
+++ b/bsp/meta-ti/recipes-bsp/osal/osal_git.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "TI OSAL library for Linux"
+
+DEPENDS="common-csl-ip"
+
+include osal.inc
+
+PR = "${INC_PR}.1"
+
+S = "${WORKDIR}/${OSAL_GIT_DESTSUFFIX}"
+
+EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR}"
+
+do_compile () {
+# Build the lib
+ oe_runmake clean
+ oe_runmake lib
+}
+
+do_install () {
+# Install the lib
+ oe_runmake install INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir}
+ chown -R root:root ${D}
+}