summaryrefslogtreecommitdiffstats
path: root/bsp/meta-ti/recipes-bsp/pm-lld/pm-lld-rtos_git.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /bsp/meta-ti/recipes-bsp/pm-lld/pm-lld-rtos_git.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'bsp/meta-ti/recipes-bsp/pm-lld/pm-lld-rtos_git.bb')
-rw-r--r--bsp/meta-ti/recipes-bsp/pm-lld/pm-lld-rtos_git.bb66
1 files changed, 66 insertions, 0 deletions
diff --git a/bsp/meta-ti/recipes-bsp/pm-lld/pm-lld-rtos_git.bb b/bsp/meta-ti/recipes-bsp/pm-lld/pm-lld-rtos_git.bb
new file mode 100644
index 00000000..33ed5ffe
--- /dev/null
+++ b/bsp/meta-ti/recipes-bsp/pm-lld/pm-lld-rtos_git.bb
@@ -0,0 +1,66 @@
+SUMMARY = "TI RTOS driver for Power Management module (PM)"
+
+inherit ti-pdk
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://Power.h;beginline=1;endline=31;md5=527b91fdcd26cd19ac07a754f45dedbe"
+
+COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|k2g|k3"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+
+PM_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/pm-lld.git"
+PM_LLD_GIT_PROTOCOL = "git"
+
+PM_LLD_GIT_BRANCH = "master"
+
+PM_LLD_GIT_BRANCH_ti33x = "int_pm_am335x"
+PM_LLD_GIT_BRANCH_ti43x = "int_pm_am335x"
+PM_LLD_GIT_BRANCH_k2g = "int_pm_am335x"
+
+PM_LLD_GIT_DESTSUFFIX = "git/ti/drv/pm"
+
+# Below commit ID corresponds to "DEV.PM_LLD.01.08.00.21"
+PM_LLD_SRCREV = "73d6a8536a420de7e7c40a4f3fd49e9e3b93ac6a"
+
+# Below commit ID corresponds to "DEV.PM_LLD.01.04.00.05C"
+PM_LLD_SRCREV_ti33x = "dd1f8486e7738956631b7f4829c8238be2e49dd6"
+PM_LLD_SRCREV_ti43x = "dd1f8486e7738956631b7f4829c8238be2e49dd6"
+PM_LLD_SRCREV_k2g = "dd1f8486e7738956631b7f4829c8238be2e49dd6"
+
+BRANCH = "${PM_LLD_GIT_BRANCH}"
+SRC_URI = "${PM_LLD_GIT_URI};destsuffix=${PM_LLD_GIT_DESTSUFFIX};protocol=${PM_LLD_GIT_PROTOCOL};branch=${BRANCH}"
+
+SRCREV = "${PM_LLD_SRCREV}"
+PV = "01.08.00.21"
+PR = "r0"
+
+S = "${WORKDIR}/${PM_LLD_GIT_DESTSUFFIX}"
+
+DEPENDS_append = " ti-sysbios \
+ osal-rtos \
+"
+DEPENDS_append_ti33x = " starterware-rtos \
+"
+DEPENDS_append_ti43x = " starterware-rtos \
+"
+
+DEPENDS_append_k3 = " sciclient-rtos \
+"
+
+export PDK_PM_ROOT_PATH = "${WORKDIR}/build"
+export DEST_ROOT="${S}"
+
+# Build with make instead of XDC
+TI_PDK_XDCMAKE = "0"
+
+do_compile_append() {
+ # Delete archive created by XDC release command since it does not contain all content
+ find -name "*.tar" -exec rm -f {} \;
+
+ # Archive from build/ to capture ti/drv/pm/ in archive
+ cd ${B}
+ tar -cf pm_lld.tar --exclude='*.tar' ./*
+}
+
+INSANE_SKIP_${PN} = "arch staticdev"