summaryrefslogtreecommitdiffstats
path: root/bsp/meta-ti/recipes-bsp/pruss-lld/pruss-lld-test_git.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /bsp/meta-ti/recipes-bsp/pruss-lld/pruss-lld-test_git.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'bsp/meta-ti/recipes-bsp/pruss-lld/pruss-lld-test_git.bb')
-rw-r--r--bsp/meta-ti/recipes-bsp/pruss-lld/pruss-lld-test_git.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/bsp/meta-ti/recipes-bsp/pruss-lld/pruss-lld-test_git.bb b/bsp/meta-ti/recipes-bsp/pruss-lld/pruss-lld-test_git.bb
new file mode 100644
index 00000000..93f19011
--- /dev/null
+++ b/bsp/meta-ti/recipes-bsp/pruss-lld/pruss-lld-test_git.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "TI PRUSS low level driver tests"
+
+DEPENDS = "common-csl-ip pruss-lld osal"
+
+include pruss-lld.inc
+
+PR = "${INC_PR}.2"
+
+S = "${WORKDIR}/${PRUSS_LLD_GIT_DESTSUFFIX}"
+
+EXTRA_OEMAKE += "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR} PRUSS_SRC_DIR=${S}"
+
+DEVICE_LIST ?= "${TI_PDK_LIMIT_SOCS}"
+
+do_compile () {
+# Build the tests
+ for device in ${DEVICE_LIST}
+ do
+ oe_runmake tests DEVICE="$device"
+ done
+}
+
+do_install () {
+# Install the binary
+ for device in ${DEVICE_LIST}
+ do
+ oe_runmake installbin INSTALL_BIN_BASE_DIR=${D}${bindir} DEVICE="$device"
+ done
+}