summaryrefslogtreecommitdiffstats
path: root/bsp/meta-ti/recipes-bsp/qmss-lld/qmss-lld_git.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /bsp/meta-ti/recipes-bsp/qmss-lld/qmss-lld_git.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'bsp/meta-ti/recipes-bsp/qmss-lld/qmss-lld_git.bb')
-rw-r--r--bsp/meta-ti/recipes-bsp/qmss-lld/qmss-lld_git.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/bsp/meta-ti/recipes-bsp/qmss-lld/qmss-lld_git.bb b/bsp/meta-ti/recipes-bsp/qmss-lld/qmss-lld_git.bb
new file mode 100644
index 00000000..a87f4905
--- /dev/null
+++ b/bsp/meta-ti/recipes-bsp/qmss-lld/qmss-lld_git.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "TI QMSS low level driver library"
+
+DEPENDS = "common-csl-ip rm-lld"
+
+include qmss-lld.inc
+
+PR = "${INC_PR}.1"
+
+do_compile () {
+# Now build the lld
+ make -f makefile_armv7 clean PDK_INSTALL_PATH=${STAGING_INCDIR}
+ for device in ${DEVICELIST}
+ do
+ make -f makefile_armv7 lib PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="${device}"
+ done
+}
+
+do_install () {
+ make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir}
+ chown -R root:root ${D}
+
+ # Set the generic device library symbolic link to default k2h
+ cd ${D}${libdir}
+
+ # Link only the first device in the list
+ for device in ${DEVICELIST}
+ do
+ ln -sf libqmss_${device}.so.1.0.0 libqmss_device.so.1
+ break
+ done
+ ln -sf libqmss_device.so.1 libqmss_device.so
+}