summaryrefslogtreecommitdiffstats
path: root/bsp/meta-ti/recipes-bsp/srio-lld
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /bsp/meta-ti/recipes-bsp/srio-lld
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'bsp/meta-ti/recipes-bsp/srio-lld')
-rw-r--r--bsp/meta-ti/recipes-bsp/srio-lld/srio-lld-rtos_git.bb17
-rw-r--r--bsp/meta-ti/recipes-bsp/srio-lld/srio-lld-test_git.bb28
-rw-r--r--bsp/meta-ti/recipes-bsp/srio-lld/srio-lld.inc26
-rw-r--r--bsp/meta-ti/recipes-bsp/srio-lld/srio-lld_git.bb20
4 files changed, 91 insertions, 0 deletions
diff --git a/bsp/meta-ti/recipes-bsp/srio-lld/srio-lld-rtos_git.bb b/bsp/meta-ti/recipes-bsp/srio-lld/srio-lld-rtos_git.bb
new file mode 100644
index 00000000..7708a18e
--- /dev/null
+++ b/bsp/meta-ti/recipes-bsp/srio-lld/srio-lld-rtos_git.bb
@@ -0,0 +1,17 @@
+SUMMARY = "TI RTOS low level driver for Serial Rapid IO (SRIO)"
+
+inherit ti-pdk
+
+require recipes-bsp/srio-lld/srio-lld.inc
+
+PR = "${INC_PR}.0"
+
+DEPENDS_append = " cppi-lld-rtos \
+ qmss-lld-rtos \
+"
+COMPATIBLE_MACHINE_append = "|c66x"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+# HTML doc link params
+PDK_COMP_LINK_TEXT = "SRIO LLD"
diff --git a/bsp/meta-ti/recipes-bsp/srio-lld/srio-lld-test_git.bb b/bsp/meta-ti/recipes-bsp/srio-lld/srio-lld-test_git.bb
new file mode 100644
index 00000000..d2a00682
--- /dev/null
+++ b/bsp/meta-ti/recipes-bsp/srio-lld/srio-lld-test_git.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "TI SRIO peripheral low level driver unit test and example binaries"
+DEPENDS="common-csl-ip rm-lld cppi-lld qmss-lld srio-lld cmem uio-module-drv"
+
+include srio-lld.inc
+
+PR = "${INC_PR}.0"
+
+CHOICELIST = "yes no"
+
+do_compile () {
+# Now build the lld in the updated directory
+ for device in ${DEVICELIST}
+ do
+ oe_runmake clean DEVICE="$device" SRIO_SRC_DIR=${S}
+ for choice in ${CHOICELIST}
+ do
+ oe_runmake tests DEVICE="$device" SRIO_SRC_DIR=${S} USEDYNAMIC_LIB="$choice"
+ oe_runmake examples DEVICE="$device" SRIO_SRC_DIR=${S} USEDYNAMIC_LIB="$choice"
+ done
+ done
+}
+
+do_install () {
+ for device in ${DEVICELIST}
+ do
+ oe_runmake installbin DEVICE="$device" SRIO_SRC_DIR=${S} INSTALL_BIN_BASE_DIR=${D}${bindir}
+ done
+}
diff --git a/bsp/meta-ti/recipes-bsp/srio-lld/srio-lld.inc b/bsp/meta-ti/recipes-bsp/srio-lld/srio-lld.inc
new file mode 100644
index 00000000..2da8245e
--- /dev/null
+++ b/bsp/meta-ti/recipes-bsp/srio-lld/srio-lld.inc
@@ -0,0 +1,26 @@
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/drv/srio/srio_drv.h;beginline=1;endline=41;md5=469096088e072d883ff7eef301b34093"
+
+COMPATIBLE_MACHINE = "k2hk"
+
+SRIO_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/srio-lld.git"
+SRIO_LLD_GIT_PROTOCOL = "git"
+SRIO_LLD_GIT_BRANCH = "master"
+SRIO_LLD_GIT_DESTSUFFIX = "git/ti/drv/srio"
+
+# commit ID corresponding to "DEV.SRIO_LLD.02.00.00.17"
+SRIO_LLD_SRCREV = "444fe581426c04c9d57f9bce6763ebe43ce284f8"
+
+BRANCH = "${SRIO_LLD_GIT_BRANCH}"
+SRC_URI = "${SRIO_LLD_GIT_URI};destsuffix=${SRIO_LLD_GIT_DESTSUFFIX};protocol=${SRIO_LLD_GIT_PROTOCOL};branch=${BRANCH}"
+SRCREV = "${SRIO_LLD_SRCREV}"
+
+PV = "02.00.00.17"
+INC_PR = "r0"
+
+DEVICELIST = "k2h k2k"
+
+BASEDIR = "${WORKDIR}/git"
+S = "${BASEDIR}/ti/drv/srio"
+
+EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR}"
diff --git a/bsp/meta-ti/recipes-bsp/srio-lld/srio-lld_git.bb b/bsp/meta-ti/recipes-bsp/srio-lld/srio-lld_git.bb
new file mode 100644
index 00000000..48e76337
--- /dev/null
+++ b/bsp/meta-ti/recipes-bsp/srio-lld/srio-lld_git.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "TI SRIO peripheral low level driver"
+
+DEPENDS="common-csl-ip rm-lld cppi-lld"
+
+include srio-lld.inc
+
+PR = "${INC_PR}.0"
+
+do_compile () {
+# Now build the lld
+ oe_runmake clean
+ for device in ${DEVICELIST}
+ do
+ oe_runmake lib DEVICE="${device}"
+ done
+}
+
+do_install () {
+ oe_runmake install INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir}
+}