summaryrefslogtreecommitdiffstats
path: root/bsp/meta-ti/recipes-bsp/traceframework/traceframework_git.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /bsp/meta-ti/recipes-bsp/traceframework/traceframework_git.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'bsp/meta-ti/recipes-bsp/traceframework/traceframework_git.bb')
-rw-r--r--bsp/meta-ti/recipes-bsp/traceframework/traceframework_git.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/bsp/meta-ti/recipes-bsp/traceframework/traceframework_git.bb b/bsp/meta-ti/recipes-bsp/traceframework/traceframework_git.bb
new file mode 100644
index 00000000..2b2020b8
--- /dev/null
+++ b/bsp/meta-ti/recipes-bsp/traceframework/traceframework_git.bb
@@ -0,0 +1,38 @@
+DESCRIPTION = "TI Trace Framework library"
+
+DEPENDS = "cuia"
+
+include traceframework.inc
+
+PR = "${INC_PR}.0"
+
+BASEDIR = "${WORKDIR}/git"
+
+EXTRA_OEMAKE += "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR} \
+ CUIA_INSTALL_DIR=${STAGING_INCDIR} CUIA_LIB_DIR=${STAGING_LIBDIR}"
+
+do_compile () {
+# making the library
+ oe_runmake clean
+ oe_runmake lib
+
+# make the test application
+ for device in ${DEVICELIST}
+ do
+ oe_runmake tests DEVICE="$device" TFW_INC_DIR=${BASEDIR} TFW_SRC_DIR=${S} \
+ TARGET_ROOT_DIR=${D}
+ done
+}
+
+do_install() {
+ for device in ${DEVICELIST}
+ do
+ oe_runmake install DEVICE="$device" TFW_SRC_DIR=${S} TARGET_ROOT_DIR=${D}
+ done
+ chown -R root:root ${D}
+}
+
+PACKAGES =+ "${PN}-test"
+
+FILES_${PN}-test = "${bindir}/tfw*.out \
+ ${bindir}/*.txt"