summaryrefslogtreecommitdiffstats
path: root/bsp/meta-ti/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /bsp/meta-ti/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'bsp/meta-ti/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend')
-rw-r--r--bsp/meta-ti/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend23
1 files changed, 23 insertions, 0 deletions
diff --git a/bsp/meta-ti/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend b/bsp/meta-ti/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
new file mode 100644
index 00000000..2dc715c8
--- /dev/null
+++ b/bsp/meta-ti/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
@@ -0,0 +1,23 @@
+BRANCH_k3 = "ti-atf"
+SRC_URI_k3 = "git://git.ti.com/atf/arm-trusted-firmware.git;branch=${BRANCH};name=tfa"
+SRCREV_tfa_k3 = "5b907a2813faf039d752cdeb6a7b94e95580c46b"
+COMPATIBLE_MACHINE_k3 = "k3"
+TFA_BUILD_TARGET_k3 = "all"
+TFA_INSTALL_TARGET_k3 = "bl31"
+TFA_SPD_k3 = "opteed"
+
+do_compile_append_am65xx-hs-evm() {
+ export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
+ ( cd ${B}/${BUILD_DIR}/release/; \
+ mv bl31.bin bl31.bin.unsigned; \
+ ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh bl31.bin.unsigned bl31.bin; \
+ )
+}
+
+do_compile_append_j7-hs-evm() {
+ export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
+ ( cd ${B}/${BUILD_DIR}/release/; \
+ mv bl31.bin bl31.bin.unsigned; \
+ ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh bl31.bin.unsigned bl31.bin; \
+ )
+}