summaryrefslogtreecommitdiffstats
path: root/bsp/meta-ti/recipes-bsp/utils-rtos/profiling-rtos_git.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /bsp/meta-ti/recipes-bsp/utils-rtos/profiling-rtos_git.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'bsp/meta-ti/recipes-bsp/utils-rtos/profiling-rtos_git.bb')
-rw-r--r--bsp/meta-ti/recipes-bsp/utils-rtos/profiling-rtos_git.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/bsp/meta-ti/recipes-bsp/utils-rtos/profiling-rtos_git.bb b/bsp/meta-ti/recipes-bsp/utils-rtos/profiling-rtos_git.bb
new file mode 100644
index 00000000..f578b7e5
--- /dev/null
+++ b/bsp/meta-ti/recipes-bsp/utils-rtos/profiling-rtos_git.bb
@@ -0,0 +1,34 @@
+SUMMARY = "TI RTOS profiling utilities"
+
+inherit ti-pdk
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://profilingver.h;beginline=1;endline=46;md5=974494ad60f33cfc0340e421c5a5a7a0"
+
+COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|keystone|c66x|k3"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+PROFILING_GIT_URI = "git://git.ti.com/keystone-rtos/utils.git"
+PROFILING_GIT_PROTOCOL = "git"
+PROFILING_GIT_BRANCH = "master"
+
+# Below commit ID corresponds to "DEV.UTILS.01.00.00.08"
+PROFILING_SRCREV = "9c30f4df9ece2d5589d5f7e977d54acf1062185c"
+
+BRANCH = "${PROFILING_GIT_BRANCH}"
+SRC_URI = "${PROFILING_GIT_URI};protocol=${PROFILING_GIT_PROTOCOL};branch=${BRANCH}"
+
+SRCREV = "${PROFILING_SRCREV}"
+PV = "01.00.00.08"
+PR = "r0"
+
+S = "${WORKDIR}/git/profiling"
+
+# Build with make instead of XDC
+TI_PDK_XDCMAKE = "0"
+
+export PDK_PROFILING_ROOT_PATH ="${WORKDIR}/build"
+export DEST_ROOT="${S}"
+
+# HTML doc link params
+PDK_COMP_LINK_TEXT = "Profiling Utility Library"