summaryrefslogtreecommitdiffstats
path: root/bsp/meta-ti/recipes-bsp/wl18xx-fw
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /bsp/meta-ti/recipes-bsp/wl18xx-fw
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'bsp/meta-ti/recipes-bsp/wl18xx-fw')
-rw-r--r--bsp/meta-ti/recipes-bsp/wl18xx-fw/wl18xx-fw/0001-Add-Makefile-to-install-firmware-files.patch29
-rw-r--r--bsp/meta-ti/recipes-bsp/wl18xx-fw/wl18xx-fw_8.7.3.bb26
2 files changed, 55 insertions, 0 deletions
diff --git a/bsp/meta-ti/recipes-bsp/wl18xx-fw/wl18xx-fw/0001-Add-Makefile-to-install-firmware-files.patch b/bsp/meta-ti/recipes-bsp/wl18xx-fw/wl18xx-fw/0001-Add-Makefile-to-install-firmware-files.patch
new file mode 100644
index 00000000..a8db0770
--- /dev/null
+++ b/bsp/meta-ti/recipes-bsp/wl18xx-fw/wl18xx-fw/0001-Add-Makefile-to-install-firmware-files.patch
@@ -0,0 +1,29 @@
+From 3a8fc3ccf00796254d6cef4b6d4cd70dc37012e1 Mon Sep 17 00:00:00 2001
+From: Denys Dmytriyenko <denys@ti.com>
+Date: Fri, 10 Mar 2017 13:28:29 -0500
+Subject: [PATCH] Add Makefile to install firmware files
+
+Signed-off-by: Denys Dmytriyenko <denys@ti.com>
+---
+ Makefile | 9 +++++++++
+ 1 file changed, 9 insertions(+)
+ create mode 100644 Makefile
+
+diff --git a/Makefile b/Makefile
+new file mode 100644
+index 0000000..1cf38e3
+--- /dev/null
++++ b/Makefile
+@@ -0,0 +1,9 @@
++# Installs the the ti-connectivity wlan firmware files into the root file system
++
++install:
++ @if [ ! -d $(DESTDIR) ] ; then \
++ echo "Target filesystem directory doesn't exist."; \
++ exit 1; \
++ fi
++ install -d $(DEST_DIR)/lib/firmware/ti-connectivity
++ cp *.bin $(DEST_DIR)/lib/firmware/ti-connectivity/
+--
+2.7.4
+
diff --git a/bsp/meta-ti/recipes-bsp/wl18xx-fw/wl18xx-fw_8.7.3.bb b/bsp/meta-ti/recipes-bsp/wl18xx-fw/wl18xx-fw_8.7.3.bb
new file mode 100644
index 00000000..a52ec898
--- /dev/null
+++ b/bsp/meta-ti/recipes-bsp/wl18xx-fw/wl18xx-fw_8.7.3.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Firmware files for use with TI wl18xx"
+LICENSE = "TI-TSPA"
+LIC_FILES_CHKSUM = "file://LICENCE;md5=4977a0fe767ee17765ae63c435a32a9e"
+
+SRC_URI = " \
+ git://git.ti.com/wilink8-wlan/wl18xx_fw.git;protocol=git;branch=${BRANCH} \
+ file://0001-Add-Makefile-to-install-firmware-files.patch \
+"
+
+# Tag: R8.7-SP3 (8.7.3)
+SRCREV = "f659be25473e4bde8dc790bff703ecacde6e21da"
+BRANCH = "master"
+
+S = "${WORKDIR}/git"
+
+CLEANBROKEN = "1"
+
+do_compile() {
+ :
+}
+
+do_install() {
+ oe_runmake 'DEST_DIR=${D}' install
+}
+
+FILES_${PN} = "/lib/firmware/ti-connectivity/*"