summaryrefslogtreecommitdiffstats
path: root/bsp/meta-ti/recipes-ti/devtools/gcc-aarch64-none-elf_9.2-2019.12.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /bsp/meta-ti/recipes-ti/devtools/gcc-aarch64-none-elf_9.2-2019.12.bb
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'bsp/meta-ti/recipes-ti/devtools/gcc-aarch64-none-elf_9.2-2019.12.bb')
-rw-r--r--bsp/meta-ti/recipes-ti/devtools/gcc-aarch64-none-elf_9.2-2019.12.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/bsp/meta-ti/recipes-ti/devtools/gcc-aarch64-none-elf_9.2-2019.12.bb b/bsp/meta-ti/recipes-ti/devtools/gcc-aarch64-none-elf_9.2-2019.12.bb
new file mode 100644
index 00000000..2ec0f9cf
--- /dev/null
+++ b/bsp/meta-ti/recipes-ti/devtools/gcc-aarch64-none-elf_9.2-2019.12.bb
@@ -0,0 +1,38 @@
+# Copyright (C) 2020 Texas Instruments Inc.
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+SUMMARY = "Baremetal GCC for Aarch64 processors"
+LICENSE = "GPL-3.0-with-GCC-exception & GPLv3"
+
+LIC_FILES_CHKSUM = "file://share/doc/gcc/GNU-Free-Documentation-License.html;md5=cc1e9a49a59ce7e6ae5ef37cd16eca0c"
+
+PROVIDES = "virtual/aarch64-none-elf-gcc"
+
+SRC_URI = "https://developer.arm.com/-/media/Files/downloads/gnu-a/9.2-2019.12/binrel/gcc-arm-${PV}-x86_64-aarch64-none-elf.tar.xz"
+
+SRC_URI[sha256sum] = "36d2cbe7c2984f2c20f562ac2f3ba524c59151adfa8ee10f1326c88de337b6d1"
+
+S = "${WORKDIR}/gcc-arm-${PV}-x86_64-aarch64-none-elf"
+
+COMPATIBLE_HOST = "x86_64.*-linux"
+
+do_install() {
+ install -d ${D}${datadir}/aarch64-none-elf/
+ cp -r ${S}/. ${D}${datadir}/aarch64-none-elf/
+
+ install -d ${D}${bindir}
+ # Symlink all executables into bindir
+ for f in ${D}${datadir}/aarch64-none-elf/bin/aarch64-none-elf-*; do
+ lnr $f ${D}${bindir}/$(basename $f)
+ done
+}
+
+FILES_${PN} = "${datadir} ${bindir}"
+
+INSANE_SKIP_${PN} = "already-stripped libdir staticdev file-rdeps"
+
+INHIBIT_SYSROOT_STRIP = "1"
+INHIBIT_PACKAGE_STRIP = "1"
+INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
+
+BBCLASSEXTEND = "native nativesdk"