summaryrefslogtreecommitdiffstats
path: root/bsp/meta-ti/recipes-ti/devtools/gcc-arm-none-eabi_7-2018-q2-update.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /bsp/meta-ti/recipes-ti/devtools/gcc-arm-none-eabi_7-2018-q2-update.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'bsp/meta-ti/recipes-ti/devtools/gcc-arm-none-eabi_7-2018-q2-update.bb')
-rw-r--r--bsp/meta-ti/recipes-ti/devtools/gcc-arm-none-eabi_7-2018-q2-update.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/bsp/meta-ti/recipes-ti/devtools/gcc-arm-none-eabi_7-2018-q2-update.bb b/bsp/meta-ti/recipes-ti/devtools/gcc-arm-none-eabi_7-2018-q2-update.bb
new file mode 100644
index 00000000..f474c87f
--- /dev/null
+++ b/bsp/meta-ti/recipes-ti/devtools/gcc-arm-none-eabi_7-2018-q2-update.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Baremetal GCC for ARM"
+LICENSE = "GPL-3.0-with-GCC-exception & GPLv3"
+
+LIC_FILES_CHKSUM = "file://share/doc/gcc-arm-none-eabi/license.txt;md5=f77466c63f5787f4bd669c402aabe061"
+
+require recipes-ti/includes/ti-paths.inc
+
+SRC_URI = "https://developer.arm.com/-/media/Files/downloads/gnu-rm/7-2018q2/gcc-arm-none-eabi-7-2018-q2-update-linux.tar.bz2;name=gcc-arm-none"
+
+SRC_URI[gcc-arm-none.md5sum] = "299ebd3f1c2c90930d28ab82e5d8d6c0"
+SRC_URI[gcc-arm-none.sha256sum] = "bb17109f0ee697254a5d4ae6e5e01440e3ea8f0277f2e8169bf95d07c7d5fe69"
+
+S = "${WORKDIR}/gcc-arm-none-eabi-7-2018-q2-update"
+
+# only x86_64 is supported
+COMPATIBLE_HOST = "x86_64.*-linux"
+COMPATIBLE_HOST_class-target = "null"
+
+do_install() {
+ install -d ${D}${GCC_ARM_NONE_TOOLCHAIN_RECIPE}
+ cp -r ${S}/. ${D}${GCC_ARM_NONE_TOOLCHAIN_RECIPE}
+}
+
+FILES_${PN} = "${GCC_ARM_NONE_TOOLCHAIN_RECIPE}/*"
+
+INSANE_SKIP_${PN} = "already-stripped libdir staticdev build-deps file-rdeps"
+INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
+
+BBCLASSEXTEND = "native nativesdk"