summaryrefslogtreecommitdiffstats
path: root/bsp/meta-ti/recipes-ti/ipc/ti-ipc-examples_git.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /bsp/meta-ti/recipes-ti/ipc/ti-ipc-examples_git.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'bsp/meta-ti/recipes-ti/ipc/ti-ipc-examples_git.bb')
-rw-r--r--bsp/meta-ti/recipes-ti/ipc/ti-ipc-examples_git.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/bsp/meta-ti/recipes-ti/ipc/ti-ipc-examples_git.bb b/bsp/meta-ti/recipes-ti/ipc/ti-ipc-examples_git.bb
new file mode 100644
index 00000000..43e45e64
--- /dev/null
+++ b/bsp/meta-ti/recipes-ti/ipc/ti-ipc-examples_git.bb
@@ -0,0 +1,46 @@
+DESCRIPTION = "TI Inter Process Communication (IPC) examples with Host running linux"
+require ti-ipc-examples.inc
+
+DEPENDS = "ti-ipc ti-xdctools-native ti-sysbios ti-ipc-rtos zip-native"
+
+DEPENDS_append_am65xx = " sciclient-rtos"
+
+do_compile_append() {
+
+ if [ "${PLATFORM}" != "UNKNOWN" ]; then
+ oe_runmake extract HOSTOS="bios" IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
+
+ for alt_platform in ${ALT_PLATFORM}; do
+ oe_runmake extract PLATFORM="${alt_platform}" HOSTOS="bios" \
+ IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
+ done
+ oe_runmake -C examples all HOSTOS="bios" \
+ IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
+ for alt_platform in ${ALT_PLATFORM}; do
+ oe_runmake -C examples all HOSTOS="bios" \
+ IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" PLATFORM="${alt_platform}"
+ done
+ fi
+}
+
+do_install_append() {
+ if [ "${PLATFORM}" != "UNKNOWN" ]; then
+ # Install directory for bios examples
+ install -d ${D}/ipc_${IPC_VERSION}/examples/bios
+ oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
+ HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios"
+ oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
+ HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios"
+
+ for alt_platform in ${ALT_PLATFORM}; do
+ oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
+ HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/${alt_platform}/bios" \
+ PLATFORM="${alt_platform}"
+ oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
+ HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/${alt_platform}/bios" \
+ PLATFORM="${alt_platform}"
+ done
+ fi
+}
+
+FILES_${PN} += "ipc_*"