summaryrefslogtreecommitdiffstats
path: root/bsp/meta-ti/recipes-ti/ipc
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-10-22 14:58:56 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-10-22 14:58:56 +0900
commit4204309872da5cb401cbb2729d9e2d4869a87f42 (patch)
treec7415e8600205e40ff7e91e8e5f4c411f30329f2 /bsp/meta-ti/recipes-ti/ipc
parent5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (diff)
Diffstat (limited to 'bsp/meta-ti/recipes-ti/ipc')
-rw-r--r--bsp/meta-ti/recipes-ti/ipc/ipc-transport-srio_git.bb1
-rw-r--r--bsp/meta-ti/recipes-ti/ipc/ipc-transport.inc6
-rw-r--r--bsp/meta-ti/recipes-ti/ipc/ti-ipc-common.inc2
-rw-r--r--bsp/meta-ti/recipes-ti/ipc/ti-ipc-rtos.inc13
-rw-r--r--bsp/meta-ti/recipes-ti/ipc/ti-ipc.inc4
5 files changed, 14 insertions, 12 deletions
diff --git a/bsp/meta-ti/recipes-ti/ipc/ipc-transport-srio_git.bb b/bsp/meta-ti/recipes-ti/ipc/ipc-transport-srio_git.bb
index f0586d8b..ca7f7b6c 100644
--- a/bsp/meta-ti/recipes-ti/ipc/ipc-transport-srio_git.bb
+++ b/bsp/meta-ti/recipes-ti/ipc/ipc-transport-srio_git.bb
@@ -13,4 +13,5 @@ do_compile () {
do_install () {
oe_runmake install INSTALL_INC_BASE_DIR=${D}${includedir} \
INSTALL_LIB_BASE_DIR=${D}${libdir}
+ chown -R root:root ${D}
}
diff --git a/bsp/meta-ti/recipes-ti/ipc/ipc-transport.inc b/bsp/meta-ti/recipes-ti/ipc/ipc-transport.inc
index 25c49e72..0c1edef1 100644
--- a/bsp/meta-ti/recipes-ti/ipc/ipc-transport.inc
+++ b/bsp/meta-ti/recipes-ti/ipc/ipc-transport.inc
@@ -4,12 +4,12 @@ IPC_TRANSPORT_GIT_URI = "git://git.ti.com/keystone-linux/ipc-transport.git"
IPC_TRANSPORT_GIT_PROTOCOL = "git"
IPC_TRANSPORT_GIT_BRANCH = "master"
-# Below commit ID corresponds to "DEV.IPC-TRANSPORT.02.00.00.02"
-IPC_TRANSPORT_SRCREV = "8cb22733115f7c1ee1e1cf3f7d704158080f383c"
+# Below commit ID corresponds to "DEV.IPC-TRANSPORT.02.00.00.02A"
+IPC_TRANSPORT_SRCREV = "f75e2e29b9b1b63443a0c82493e41dd2f771c6f5"
BRANCH = "${IPC_TRANSPORT_GIT_BRANCH}"
SRC_URI = "${IPC_TRANSPORT_GIT_URI};protocol=${IPC_TRANSPORT_GIT_PROTOCOL};branch=${BRANCH}"
SRCREV = "${IPC_TRANSPORT_SRCREV}"
-PV = "02.00.00.02"
+PV = "02.00.00.02A"
INC_PR = "r0"
diff --git a/bsp/meta-ti/recipes-ti/ipc/ti-ipc-common.inc b/bsp/meta-ti/recipes-ti/ipc/ti-ipc-common.inc
index 036e46d8..86a0fd0c 100644
--- a/bsp/meta-ti/recipes-ti/ipc/ti-ipc-common.inc
+++ b/bsp/meta-ti/recipes-ti/ipc/ti-ipc-common.inc
@@ -1,4 +1,4 @@
-PV = "3.50.03.05"
+PV = "3.50.04.08"
INC_PR = "r0"
PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/bsp/meta-ti/recipes-ti/ipc/ti-ipc-rtos.inc b/bsp/meta-ti/recipes-ti/ipc/ti-ipc-rtos.inc
index dcd6309f..4d0d449c 100644
--- a/bsp/meta-ti/recipes-ti/ipc/ti-ipc-rtos.inc
+++ b/bsp/meta-ti/recipes-ti/ipc/ti-ipc-rtos.inc
@@ -24,10 +24,10 @@ protocol=${TI_IPC_METADATA_GIT_PROTOCOL};\
branch=${TI_IPC_METADATA_GIT_BRANCH};\
name=${TI_IPC_METADATA_NAME}"
-# Corresponds to tag: 3.50.03.05
-TI_IPC_METADATA_SRCREV = "3936c41d021c6d56c25f4bb07b647314a6589a57"
-# Corresponds to tag: 3.50.03.05
-TI_IPC_EXAMPLES_SRCREV = "55a8341c60a91c0ba2d79b7e4b805e2e39b3060f"
+# Corresponds to tag: 3.50.04.08
+TI_IPC_METADATA_SRCREV = "48788ea79190c4995df4c802e8aa4e17f332943d"
+# Corresponds to tag: 3.50.04.08
+TI_IPC_EXAMPLES_SRCREV = "4707fcbbe0d136e781c4a7ffdc072be407c34358"
SRCREV_FORMAT = "default"
SRCREV_ipc-metadata = "${TI_IPC_METADATA_SRCREV}"
@@ -39,7 +39,7 @@ S_ipc-metadata = "${WORKDIR}/git/ipc-metadata"
RELEASE_TYPE = "GA"
RELEASE_SUFFIX = ""
-PR = "${INC_PR}.r0"
+PR = "${INC_PR}.r2"
DEPENDS_append_keystone = " ti-cgt6x-native \
gcc-arm-none-eabi-native \
@@ -84,12 +84,13 @@ IPC_TARGETS_am65xx = "\
ti.targets.arm.elf.R5F="${M4_TOOLCHAIN_INSTALL_DIR}" \
"
+PARALLEL_XDC = "${@oe.utils.parallel_make_argument(d, '--jobs=%d')}"
EXTRA_OEMAKE = "\
PLATFORM=${PLATFORM} \
XDC_INSTALL_DIR="${XDC_INSTALL_DIR}" \
BIOS_INSTALL_DIR="${SYSBIOS_INSTALL_DIR}" \
${IPC_TARGETS} \
- JOBS="--jobs=${BB_NUMBER_THREADS}" \
+ ${PARALLEL_XDC} \
JAVA_TOOL_OPTIONS=-Xss2560k \
"
EXTRA_OEMAKE_append_am65xx = " PDK_INSTALL_DIR=${PDK_INSTALL_DIR}"
diff --git a/bsp/meta-ti/recipes-ti/ipc/ti-ipc.inc b/bsp/meta-ti/recipes-ti/ipc/ti-ipc.inc
index 482fdcc2..d1eaad2a 100644
--- a/bsp/meta-ti/recipes-ti/ipc/ti-ipc.inc
+++ b/bsp/meta-ti/recipes-ti/ipc/ti-ipc.inc
@@ -8,8 +8,8 @@ TI_IPC_GIT_URI = "git://git.ti.com/ipc/ipcdev.git"
TI_IPC_GIT_PROTOCOL = "git"
TI_IPC_GIT_BRANCH = "3.50"
-#Corresponds to 3.50.03.05
-TI_IPC_SRCREV = "7007b8adff409fd8c90757c9adafd264a3ff15e3"
+#Corresponds to 3.50.04.08
+TI_IPC_SRCREV = "1d53b856338b86d1979fe09345c0b382913a848a"
BRANCH = "${TI_IPC_GIT_BRANCH}"
SRC_URI = "${TI_IPC_GIT_URI};protocol=${TI_IPC_GIT_PROTOCOL};branch=${BRANCH};name=ipcdev"