summaryrefslogtreecommitdiffstats
path: root/bsp/meta-ti/recipes-ti/multiprocmgr/multiprocmgr_git.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /bsp/meta-ti/recipes-ti/multiprocmgr/multiprocmgr_git.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'bsp/meta-ti/recipes-ti/multiprocmgr/multiprocmgr_git.bb')
-rw-r--r--bsp/meta-ti/recipes-ti/multiprocmgr/multiprocmgr_git.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/bsp/meta-ti/recipes-ti/multiprocmgr/multiprocmgr_git.bb b/bsp/meta-ti/recipes-ti/multiprocmgr/multiprocmgr_git.bb
new file mode 100644
index 00000000..6143341d
--- /dev/null
+++ b/bsp/meta-ti/recipes-ti/multiprocmgr/multiprocmgr_git.bb
@@ -0,0 +1,47 @@
+DESCRIPTION = "TI Multiproc Manager for KeyStone II"
+SUMMARY = "Provides download, debug and other utilities for other cores in the SOC like DSP"
+
+include multiprocmgr.inc
+
+SRC_URI += " \
+ file://mpmsrv-daemon.service \
+ file://0001-mpmdlif.c-don-t-hardcode-kernel-s-uapi-location-keys.patch \
+"
+
+PR = "${INC_PR}.2"
+
+DEPENDS = "mpm-transport libdaemon virtual/kernel cmem"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+CC += "-I${STAGING_KERNEL_DIR}/include -I${STAGING_KERNEL_DIR}/include/uapi"
+
+INITSCRIPT_NAME = "mpmsrv-daemon.sh"
+INITSCRIPT_PARAMS = "defaults 10"
+
+SYSTEMD_SERVICE_${PN} = "mpmsrv-daemon.service"
+
+inherit update-rc.d systemd
+
+do_install() {
+ install -d ${D}${bindir}/
+ install -c -m 755 ${S}/bin/mpmsrv ${D}${bindir}/mpmsrv
+ install -c -m 755 ${S}/bin/mpmcl ${D}${bindir}/mpmcl
+
+ install -d ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/mpmsrv-daemon.service ${D}${systemd_system_unitdir}
+ install -d ${D}${sysconfdir}/init.d/
+ install -c -m 755 ${S}/scripts/mpmsrv-daemon.sh ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
+
+ install -d ${D}${sysconfdir}/mpm/
+ install -c -m 755 ${S}/scripts/crash_callback.sh ${D}${sysconfdir}/mpm/crash_callback.sh
+
+ install -d ${D}${includedir}/
+ install -c -m 755 ${S}/include/* ${D}${includedir}/
+
+ install -d ${D}${libdir}/
+ cp -a ${S}/lib/* ${D}${libdir}/
+ chown -R root:root ${D}${libdir}/
+}
+
+INSANE_SKIP_${PN} = "ldflags"