summaryrefslogtreecommitdiffstats
path: root/bsp/meta-ti/recipes-ti/ti-softhsmv2/ti-softhsmv2_git.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /bsp/meta-ti/recipes-ti/ti-softhsmv2/ti-softhsmv2_git.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'bsp/meta-ti/recipes-ti/ti-softhsmv2/ti-softhsmv2_git.bb')
-rw-r--r--bsp/meta-ti/recipes-ti/ti-softhsmv2/ti-softhsmv2_git.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/bsp/meta-ti/recipes-ti/ti-softhsmv2/ti-softhsmv2_git.bb b/bsp/meta-ti/recipes-ti/ti-softhsmv2/ti-softhsmv2_git.bb
new file mode 100644
index 00000000..d281a515
--- /dev/null
+++ b/bsp/meta-ti/recipes-ti/ti-softhsmv2/ti-softhsmv2_git.bb
@@ -0,0 +1,48 @@
+DESCRIPTION = "TI softhsmv2 package"
+LICENSE = "BSD-2-Clause | BSD-3-Clause | ISC | IBM-License | FSFULLR | Zlib"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=700a883962ccff663f888f3f7221ce8f"
+SECTION = "libs"
+
+mntdir = "/mnt"
+
+inherit autotools pkgconfig
+
+DEPENDS = "openssl10 libdaemon zlib"
+COMPATIBLE_MACHINE = "keystone"
+
+BRANCH = "ti-softhsm-rebase"
+SRC_URI = "git://git.ti.com/keystone-linux/ti-softhsmv2.git;protocol=git;branch=${BRANCH}"
+#Following commit corresponds to tag DEV.SOFTHSM-02.00.00.00
+SRCREV = "b0eef602c03583e59c289ba113b64eaa4f5cac13"
+PV = "2.0.0.0"
+PR = "r0"
+
+S = "${WORKDIR}/git"
+
+CFLAGS += "-mno-unaligned-access"
+CPPFLAGS += "-mno-unaligned-access"
+
+EXTRA_OECONF += " \
+ --with-zlib=${STAGING_EXECPREFIXDIR} \
+ --with-openssl=${STAGING_EXECPREFIXDIR} \
+"
+
+INITSCRIPT_NAME = "softhsm-daemon.sh"
+INITSCRIPT_PARAMS = "defaults 10"
+
+inherit update-rc.d
+
+FILES_${PN} += "${libdir}/softhsm/lib*.so.* ${mntdir}/*"
+FILES_${PN}-dbg += "${libdir}/softhsm/.debug"
+FILES_${PN}-staticdev += "${libdir}/softhsm/*.a"
+FILES_${PN}-dev += "${libdir}/softhsm/*.la ${libdir}/softhsm/lib*.so"
+
+INSANE_SKIP_${PN}-dev = "dev-elf"
+
+do_install_append() {
+ install -d ${D}${mntdir}/securedbv0
+ install -d ${D}${mntdir}/securedbv1
+
+ install -d ${D}${sysconfdir}/init.d/
+ install -c -m 755 ${S}/src/bin/daemon/softhsm-daemon.sh ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
+}