summaryrefslogtreecommitdiffstats
path: root/external/meta-clang/recipes-core/musl/musl_%.bbappend
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/meta-clang/recipes-core/musl/musl_%.bbappend
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/meta-clang/recipes-core/musl/musl_%.bbappend')
-rw-r--r--external/meta-clang/recipes-core/musl/musl_%.bbappend11
1 files changed, 11 insertions, 0 deletions
diff --git a/external/meta-clang/recipes-core/musl/musl_%.bbappend b/external/meta-clang/recipes-core/musl/musl_%.bbappend
index c8b9878e..a6a1bf54 100644
--- a/external/meta-clang/recipes-core/musl/musl_%.bbappend
+++ b/external/meta-clang/recipes-core/musl/musl_%.bbappend
@@ -1 +1,12 @@
DEPENDS_append_toolchain-clang = " clang-cross-${TARGET_ARCH}"
+TOOLCHAIN_x86-x32 = "gcc"
+TOOLCHAIN_riscv64 = "gcc"
+TOOLCHAIN_powerpc64 = "gcc"
+
+inherit lto
+
+# workaround until https://bugs.llvm.org/show_bug.cgi?id=44384
+# is fixed
+do_configure_prepend_toolchain-clang () {
+ sed -i -e '/frounding-math/d' ${S}/configure
+}