summaryrefslogtreecommitdiffstats
path: root/external/meta-clang/recipes-devtools/clang/clang/0002-compiler-rt-Simplify-cross-compilation.-Don-t-use-na.patch
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/meta-clang/recipes-devtools/clang/clang/0002-compiler-rt-Simplify-cross-compilation.-Don-t-use-na.patch
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/meta-clang/recipes-devtools/clang/clang/0002-compiler-rt-Simplify-cross-compilation.-Don-t-use-na.patch')
-rw-r--r--external/meta-clang/recipes-devtools/clang/clang/0002-compiler-rt-Simplify-cross-compilation.-Don-t-use-na.patch46
1 files changed, 0 insertions, 46 deletions
diff --git a/external/meta-clang/recipes-devtools/clang/clang/0002-compiler-rt-Simplify-cross-compilation.-Don-t-use-na.patch b/external/meta-clang/recipes-devtools/clang/clang/0002-compiler-rt-Simplify-cross-compilation.-Don-t-use-na.patch
deleted file mode 100644
index 2ff903b1..00000000
--- a/external/meta-clang/recipes-devtools/clang/clang/0002-compiler-rt-Simplify-cross-compilation.-Don-t-use-na.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From 5ee148af76169aa327bfa0bfc1c2618a68e873fb Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Thu, 19 May 2016 23:11:45 -0700
-Subject: [PATCH 2/4] compiler-rt: Simplify cross-compilation. Don't use
- native-compiled llvm-config.
-
- Note: AddLLVM.cmake does not expose the LLVM source directory.
- So if you want to run the test suite, you need to either:
-
- 1) set LLVM_MAIN_SRC_DIR explicitly (to find lit.py)
- 2) change AddLLVM.cmake to point to an installed 'lit'.
- 3) add_subdirectory(compiler-rt/test) from clang instead of compiler-rt.
-
-https://us.codeaurora.org/patches/quic/llvm/50683/compiler-rt-cross-compilation.patch
-
-Signed-off-by: Greg Fitzgerald <gregf@codeaurora.org>
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- CMakeLists.txt | 11 ++++++++++-
- 1 file changed, 10 insertions(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 86ca2b3ef..07d894c8a 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -63,7 +63,16 @@ set(COMPILER_RT_BAREMETAL_BUILD OFF CACHE BOOLEAN
- "Build for a bare-metal target.")
-
- if (COMPILER_RT_STANDALONE_BUILD)
-- load_llvm_config()
-+ find_package(LLVM REQUIRED)
-+ list(APPEND CMAKE_MODULE_PATH "${LLVM_CMAKE_DIR}")
-+
-+ # Variables that AddLLVM.cmake depends on (included by AddCompilerRT)
-+ set(LLVM_TOOLS_BINARY_DIR "${LLVM_INSTALL_PREFIX}/bin")
-+ set(LLVM_LIBRARY_DIR "${LLVM_INSTALL_PREFIX}/lib")
-+
-+ set(LLVM_LIBRARY_OUTPUT_INTDIR
-+ ${CMAKE_BINARY_DIR}/${CMAKE_CFG_INTDIR}/lib${LLVM_LIBDIR_SUFFIX})
-+
- if (TARGET intrinsics_gen)
- # Loading the llvm config causes this target to be imported so place it
- # under the appropriate folder in an IDE.
---
-2.20.1
-