summaryrefslogtreecommitdiffstats
path: root/external/meta-gplv2/recipes-support/nettle/files/Add-target-to-only-build-tests-not-run-them.patch
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /external/meta-gplv2/recipes-support/nettle/files/Add-target-to-only-build-tests-not-run-them.patch
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'external/meta-gplv2/recipes-support/nettle/files/Add-target-to-only-build-tests-not-run-them.patch')
-rw-r--r--external/meta-gplv2/recipes-support/nettle/files/Add-target-to-only-build-tests-not-run-them.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/external/meta-gplv2/recipes-support/nettle/files/Add-target-to-only-build-tests-not-run-them.patch b/external/meta-gplv2/recipes-support/nettle/files/Add-target-to-only-build-tests-not-run-them.patch
new file mode 100644
index 00000000..af77aec4
--- /dev/null
+++ b/external/meta-gplv2/recipes-support/nettle/files/Add-target-to-only-build-tests-not-run-them.patch
@@ -0,0 +1,44 @@
+From 9225dfb91b6b5617cf2dff32d370cf027237d4c8 Mon Sep 17 00:00:00 2001
+From: Jussi Kukkonen <jussi.kukkonen@intel.com>
+Date: Wed, 12 Aug 2015 23:27:27 +0300
+Subject: [PATCH] Add target to only build tests (not run them)
+
+Not sending upstream as this is only a start of a solution to
+installable tests: It's useful for us already as is.
+
+Upstream-Status: Inappropriate [not a complete solution]
+
+Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
+
+---
+ Makefile.in | 3 +++
+ testsuite/Makefile.in | 2 ++
+ 2 files changed, 5 insertions(+)
+
+diff --git a/Makefile.in b/Makefile.in
+index 2c25007..ef21b1b 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -53,6 +53,9 @@ clean distclean mostlyclean maintainer-clean tags:
+ echo "Making $@ in $$d" ; (cd $$d && $(MAKE) $@); done
+ $(MAKE) $@-here
+
++buildtest:
++ echo "Making $@ in testsuite" ; (cd testsuite && $(MAKE) $@)
++
+ check-here:
+ true
+
+diff --git a/testsuite/Makefile.in b/testsuite/Makefile.in
+index 91f6e2a..52f5c29 100644
+--- a/testsuite/Makefile.in
++++ b/testsuite/Makefile.in
+@@ -105,6 +105,8 @@ $(TARGETS) $(EXTRA_TARGETS): testutils.$(OBJEXT) ../nettle-internal.$(OBJEXT) \
+
+ VALGRIND = valgrind --error-exitcode=1 --leak-check=full --show-reachable=yes
+
++buildtest: $(TS_ALL)
++
+ # The PATH update is for locating dlls on w*ndows.
+ check: $(TS_ALL)
+ LD_LIBRARY_PATH=../.lib PATH="../.lib:$$PATH" srcdir="$(srcdir)" \