summaryrefslogtreecommitdiffstats
path: root/external/meta-gplv2/recipes-support/shared-mime-info/shared-mime-info/parallelmake.patch
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/meta-gplv2/recipes-support/shared-mime-info/shared-mime-info/parallelmake.patch
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/meta-gplv2/recipes-support/shared-mime-info/shared-mime-info/parallelmake.patch')
-rw-r--r--external/meta-gplv2/recipes-support/shared-mime-info/shared-mime-info/parallelmake.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/external/meta-gplv2/recipes-support/shared-mime-info/shared-mime-info/parallelmake.patch b/external/meta-gplv2/recipes-support/shared-mime-info/shared-mime-info/parallelmake.patch
new file mode 100644
index 00000000..fea34a55
--- /dev/null
+++ b/external/meta-gplv2/recipes-support/shared-mime-info/shared-mime-info/parallelmake.patch
@@ -0,0 +1,33 @@
+The Makefile used by shared-mime-info is one big race with the SUBDIRS
+option and the dependency specifically calling make all combining to
+create multiple make instances all of which may try and build targets
+like update-mime-database.
+
+This patch removes those options meaning make can correctly identify
+dependencies and stop itself racing itself.
+
+RP 10/10/2011
+
+Upstream-Status: Pending
+Signed-off-by: Constantin Musca <constantinx.musca@intel.com>
+
+Index: shared-mime-info-1.9/Makefile.am
+===================================================================
+--- shared-mime-info-1.9.orig/Makefile.am
++++ shared-mime-info-1.9/Makefile.am
+@@ -1,5 +1,3 @@
+-SUBDIRS=. po
+-
+ AM_CPPFLAGS = $(ALL_CFLAGS)
+
+ packagesdir = $(datadir)/mime/packages
+@@ -81,8 +79,7 @@ endif
+
+ all: $(defaultmakedeps)
+
+-create-pot:
+- $(AM_V_GEN) $(MAKE) -C po shared-mime-info.pot
++create-pot: po
+
+ local-test: create-pot freedesktop.org.xml update-mime-database$(EXEEXT)
+ if CROSS_COMPILING