summaryrefslogtreecommitdiffstats
path: root/external/meta-iot-cloud/recipes-aws/python/python-botocore/Allow-python-dateutil-2.8.1.patch
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/meta-iot-cloud/recipes-aws/python/python-botocore/Allow-python-dateutil-2.8.1.patch
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/meta-iot-cloud/recipes-aws/python/python-botocore/Allow-python-dateutil-2.8.1.patch')
-rw-r--r--external/meta-iot-cloud/recipes-aws/python/python-botocore/Allow-python-dateutil-2.8.1.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/external/meta-iot-cloud/recipes-aws/python/python-botocore/Allow-python-dateutil-2.8.1.patch b/external/meta-iot-cloud/recipes-aws/python/python-botocore/Allow-python-dateutil-2.8.1.patch
new file mode 100644
index 00000000..3ab6e915
--- /dev/null
+++ b/external/meta-iot-cloud/recipes-aws/python/python-botocore/Allow-python-dateutil-2.8.1.patch
@@ -0,0 +1,36 @@
+From d6c1ab03920d553c6022016dba3a5816c2390043 Mon Sep 17 00:00:00 2001
+From: Alex Kiernan <alex.kiernan@gmail.com>
+Date: Sat, 23 Nov 2019 05:44:58 +0000
+Subject: [PATCH] setup: Allow python-dateutil 2.8.1
+
+Upstream-Status: Inappropriate [https://github.com/boto/botocore/issues/1872#issuecomment-549612354]
+---
+ botocore.egg-info/requires.txt | 2 +-
+ setup.py | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/botocore.egg-info/requires.txt b/botocore.egg-info/requires.txt
+index a1eadc8d0abc..5080ea4500f0 100644
+--- a/botocore.egg-info/requires.txt
++++ b/botocore.egg-info/requires.txt
+@@ -1,6 +1,6 @@
+ jmespath<1.0.0,>=0.7.1
+ docutils<0.16,>=0.10
+-python-dateutil<2.8.1,>=2.1
++python-dateutil<=2.8.1,>=2.1
+ urllib3<1.26,>=1.20
+
+ [:python_version=="2.6"]
+diff --git a/setup.py b/setup.py
+index c62ab875fc1a..a4bfd3d04892 100644
+--- a/setup.py
++++ b/setup.py
+@@ -40,7 +40,7 @@ if sys.version_info[:2] == (2, 6):
+ requires.append('simplejson==3.3.0')
+ requires.append('python-dateutil>=2.1,<2.7.0')
+ else:
+- requires.append('python-dateutil>=2.1,<2.8.1')
++ requires.append('python-dateutil>=2.1,<=2.8.1')
+
+ if sys.version_info[:2] == (2, 6):
+ requires.append('urllib3>=1.20,<1.24')