summaryrefslogtreecommitdiffstats
path: root/external/meta-iot-cloud/recipes-aws/python/python-gg-group-setup.inc
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/meta-iot-cloud/recipes-aws/python/python-gg-group-setup.inc
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/meta-iot-cloud/recipes-aws/python/python-gg-group-setup.inc')
-rw-r--r--external/meta-iot-cloud/recipes-aws/python/python-gg-group-setup.inc25
1 files changed, 25 insertions, 0 deletions
diff --git a/external/meta-iot-cloud/recipes-aws/python/python-gg-group-setup.inc b/external/meta-iot-cloud/recipes-aws/python/python-gg-group-setup.inc
new file mode 100644
index 00000000..03132d1b
--- /dev/null
+++ b/external/meta-iot-cloud/recipes-aws/python/python-gg-group-setup.inc
@@ -0,0 +1,25 @@
+SUMMARY = "A file-driven approach to the creation of an entire AWS Greengrass group"
+AUTHOR = "Brett Francis <brettf@amazon.com>"
+HOMEPAGE = "https://github.com/awslabs/aws-greengrass-group-setup"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+PYPI_PACKAGE = "gg_group_setup"
+
+SRC_URI[md5sum] = "afc38bf424421634bea65fe32f2a32dd"
+SRC_URI[sha256sum] = "5d68dc5007a1bf24e8d1415db93e4f2b4dde42ffd98b868778bb3f6522d4d89d"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-setuptools \
+ ${PYTHON_PN}-boto3 \
+ ${PYTHON_PN}-fire \
+ ${PYTHON_PN}-misc \
+"
+
+do_configure_prepend() {
+ sed -i \
+ -e 's:from gg_group_setup import __version__:__version__ = "${PV}":' \
+ ${S}/setup.py
+}
+
+inherit pypi