summaryrefslogtreecommitdiffstats
path: root/external/meta-iot-cloud/recipes-aws/python
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/meta-iot-cloud/recipes-aws/python
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/meta-iot-cloud/recipes-aws/python')
-rw-r--r--external/meta-iot-cloud/recipes-aws/python/python-awscli.inc29
-rw-r--r--external/meta-iot-cloud/recipes-aws/python/python-boto3.inc18
-rw-r--r--external/meta-iot-cloud/recipes-aws/python/python-botocore.inc33
-rw-r--r--external/meta-iot-cloud/recipes-aws/python/python-botocore/Allow-python-dateutil-2.8.1.patch36
-rw-r--r--external/meta-iot-cloud/recipes-aws/python/python-gg-group-setup.inc25
-rw-r--r--external/meta-iot-cloud/recipes-aws/python/python-s3transfer.inc10
-rw-r--r--external/meta-iot-cloud/recipes-aws/python/python3-awscli_1.16.278.bb22
-rw-r--r--external/meta-iot-cloud/recipes-aws/python/python3-boto3_1.10.25.bb2
-rw-r--r--external/meta-iot-cloud/recipes-aws/python/python3-botocore_1.13.26.bb2
-rw-r--r--external/meta-iot-cloud/recipes-aws/python/python3-gg-group-setup_0.5.3.bb10
-rw-r--r--external/meta-iot-cloud/recipes-aws/python/python3-s3transfer_0.2.1.bb8
11 files changed, 195 insertions, 0 deletions
diff --git a/external/meta-iot-cloud/recipes-aws/python/python-awscli.inc b/external/meta-iot-cloud/recipes-aws/python/python-awscli.inc
new file mode 100644
index 00000000..d882092b
--- /dev/null
+++ b/external/meta-iot-cloud/recipes-aws/python/python-awscli.inc
@@ -0,0 +1,29 @@
+DESCRIPTION = "This package provides a unified command line interface to Amazon Web Services."
+HOMEPAGE = "https://github.com/aws/aws-cli"
+AUTHOR = "Amazon Web Services"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=71a3e14f29ac5c23e1b5b934ca4ddfc9"
+
+RDEPENDS_${PN} += "\
+ groff \
+ less \
+ ${PYTHON_PN}-botocore \
+ ${PYTHON_PN}-colorama \
+ ${PYTHON_PN}-ctypes \
+ ${PYTHON_PN}-difflib \
+ ${PYTHON_PN}-docutils \
+ ${PYTHON_PN}-misc \
+ ${PYTHON_PN}-pyyaml \
+ ${PYTHON_PN}-rsa \
+ ${PYTHON_PN}-s3transfer \
+ ${PYTHON_PN}-unixadmin \
+"
+
+PR = "r0"
+
+SRC_NAME = "aws-cli"
+
+SRC_URI = "git://github.com/aws/${SRC_NAME}.git"
+SRCREV = "59338c88372e5e15b57b438061d007dfeb0fbc3f"
+
+S = "${WORKDIR}/git"
diff --git a/external/meta-iot-cloud/recipes-aws/python/python-boto3.inc b/external/meta-iot-cloud/recipes-aws/python/python-boto3.inc
new file mode 100644
index 00000000..a3eafbe2
--- /dev/null
+++ b/external/meta-iot-cloud/recipes-aws/python/python-boto3.inc
@@ -0,0 +1,18 @@
+DESCRIPTION = "The AWS SDK for Python"
+HOMEPAGE = "https://aws.amazon.com/sdk-for-python/"
+AUTHOR = "Amazon Web Services"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+SRC_URI[md5sum] = "a18e37ff05d0dd0a59e43e7bcfd79469"
+SRC_URI[sha256sum] = "b9c930982891229fe32c670c940835e4d5afcb52f60a5e512de8e5cba409900b"
+
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-botocore \
+ ${PYTHON_PN}-jmespath \
+ ${PYTHON_PN}-s3transfer \
+"
+
+inherit pypi
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/external/meta-iot-cloud/recipes-aws/python/python-botocore.inc b/external/meta-iot-cloud/recipes-aws/python/python-botocore.inc
new file mode 100644
index 00000000..38b5081e
--- /dev/null
+++ b/external/meta-iot-cloud/recipes-aws/python/python-botocore.inc
@@ -0,0 +1,33 @@
+DESCRIPTION = "Low-level, data-driven core of boto 3."
+HOMEPAGE = "https://github.com/boto/botocore"
+AUTHOR = "Amazon Web Services"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2ee41112a44fe7014dce33e26468ba93"
+
+SRC_URI[md5sum] = "c7cb165153055aa16168dd3700adb032"
+SRC_URI[sha256sum] = "ee55ce128056c5120680d25c8e8dfa3a08dbe7ac3445dc16997daaa68ae4060e"
+
+inherit pypi
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/python-botocore:"
+
+SRC_URI += "\
+ file://Allow-python-dateutil-2.8.1.patch \
+"
+
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-jmespath \
+ ${PYTHON_PN}-dateutil \
+ ${PYTHON_PN}-docutils \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-netserver \
+ ${PYTHON_PN}-email \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-html \
+ ${PYTHON_PN}-urllib3 \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-unixadmin \
+"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/external/meta-iot-cloud/recipes-aws/python/python-botocore/Allow-python-dateutil-2.8.1.patch b/external/meta-iot-cloud/recipes-aws/python/python-botocore/Allow-python-dateutil-2.8.1.patch
new file mode 100644
index 00000000..3ab6e915
--- /dev/null
+++ b/external/meta-iot-cloud/recipes-aws/python/python-botocore/Allow-python-dateutil-2.8.1.patch
@@ -0,0 +1,36 @@
+From d6c1ab03920d553c6022016dba3a5816c2390043 Mon Sep 17 00:00:00 2001
+From: Alex Kiernan <alex.kiernan@gmail.com>
+Date: Sat, 23 Nov 2019 05:44:58 +0000
+Subject: [PATCH] setup: Allow python-dateutil 2.8.1
+
+Upstream-Status: Inappropriate [https://github.com/boto/botocore/issues/1872#issuecomment-549612354]
+---
+ botocore.egg-info/requires.txt | 2 +-
+ setup.py | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/botocore.egg-info/requires.txt b/botocore.egg-info/requires.txt
+index a1eadc8d0abc..5080ea4500f0 100644
+--- a/botocore.egg-info/requires.txt
++++ b/botocore.egg-info/requires.txt
+@@ -1,6 +1,6 @@
+ jmespath<1.0.0,>=0.7.1
+ docutils<0.16,>=0.10
+-python-dateutil<2.8.1,>=2.1
++python-dateutil<=2.8.1,>=2.1
+ urllib3<1.26,>=1.20
+
+ [:python_version=="2.6"]
+diff --git a/setup.py b/setup.py
+index c62ab875fc1a..a4bfd3d04892 100644
+--- a/setup.py
++++ b/setup.py
+@@ -40,7 +40,7 @@ if sys.version_info[:2] == (2, 6):
+ requires.append('simplejson==3.3.0')
+ requires.append('python-dateutil>=2.1,<2.7.0')
+ else:
+- requires.append('python-dateutil>=2.1,<2.8.1')
++ requires.append('python-dateutil>=2.1,<=2.8.1')
+
+ if sys.version_info[:2] == (2, 6):
+ requires.append('urllib3>=1.20,<1.24')
diff --git a/external/meta-iot-cloud/recipes-aws/python/python-gg-group-setup.inc b/external/meta-iot-cloud/recipes-aws/python/python-gg-group-setup.inc
new file mode 100644
index 00000000..03132d1b
--- /dev/null
+++ b/external/meta-iot-cloud/recipes-aws/python/python-gg-group-setup.inc
@@ -0,0 +1,25 @@
+SUMMARY = "A file-driven approach to the creation of an entire AWS Greengrass group"
+AUTHOR = "Brett Francis <brettf@amazon.com>"
+HOMEPAGE = "https://github.com/awslabs/aws-greengrass-group-setup"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+PYPI_PACKAGE = "gg_group_setup"
+
+SRC_URI[md5sum] = "afc38bf424421634bea65fe32f2a32dd"
+SRC_URI[sha256sum] = "5d68dc5007a1bf24e8d1415db93e4f2b4dde42ffd98b868778bb3f6522d4d89d"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-setuptools \
+ ${PYTHON_PN}-boto3 \
+ ${PYTHON_PN}-fire \
+ ${PYTHON_PN}-misc \
+"
+
+do_configure_prepend() {
+ sed -i \
+ -e 's:from gg_group_setup import __version__:__version__ = "${PV}":' \
+ ${S}/setup.py
+}
+
+inherit pypi
diff --git a/external/meta-iot-cloud/recipes-aws/python/python-s3transfer.inc b/external/meta-iot-cloud/recipes-aws/python/python-s3transfer.inc
new file mode 100644
index 00000000..ebd9c404
--- /dev/null
+++ b/external/meta-iot-cloud/recipes-aws/python/python-s3transfer.inc
@@ -0,0 +1,10 @@
+DESCRIPTION = "An Amazon S3 Transfer Manager"
+HOMEPAGE = "https://github.com/boto/s3transfer/"
+AUTHOR = "Amazon Web Services"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b1e01b26bacfc2232046c90a330332b3"
+
+SRC_URI[md5sum] = "8ca74015d9dc58af26c68276a8867eca"
+SRC_URI[sha256sum] = "6efc926738a3cd576c2a79725fed9afde92378aa5c6a957e3af010cb019fac9d"
+
+inherit pypi
diff --git a/external/meta-iot-cloud/recipes-aws/python/python3-awscli_1.16.278.bb b/external/meta-iot-cloud/recipes-aws/python/python3-awscli_1.16.278.bb
new file mode 100644
index 00000000..b3942614
--- /dev/null
+++ b/external/meta-iot-cloud/recipes-aws/python/python3-awscli_1.16.278.bb
@@ -0,0 +1,22 @@
+inherit setuptools3 update-alternatives
+require python-awscli.inc
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-asyncio \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-threading \
+"
+
+do_install_append() {
+ sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' ${D}${bindir}/aws
+}
+
+ALTERNATIVE_${PN} = "\
+ aws \
+ aws_completer \
+"
+
+ALTERNATIVE_LINK_NAME[aws] = "${bindir}/aws"
+ALTERNATIVE_LINK_NAME[aws_completer] = "${bindir}/aws_completer"
+
+ALTERNATIVE_PRIORITY = "30"
diff --git a/external/meta-iot-cloud/recipes-aws/python/python3-boto3_1.10.25.bb b/external/meta-iot-cloud/recipes-aws/python/python3-boto3_1.10.25.bb
new file mode 100644
index 00000000..be16373c
--- /dev/null
+++ b/external/meta-iot-cloud/recipes-aws/python/python3-boto3_1.10.25.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-boto3.inc
diff --git a/external/meta-iot-cloud/recipes-aws/python/python3-botocore_1.13.26.bb b/external/meta-iot-cloud/recipes-aws/python/python3-botocore_1.13.26.bb
new file mode 100644
index 00000000..82c9d387
--- /dev/null
+++ b/external/meta-iot-cloud/recipes-aws/python/python3-botocore_1.13.26.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-botocore.inc
diff --git a/external/meta-iot-cloud/recipes-aws/python/python3-gg-group-setup_0.5.3.bb b/external/meta-iot-cloud/recipes-aws/python/python3-gg-group-setup_0.5.3.bb
new file mode 100644
index 00000000..f26a4987
--- /dev/null
+++ b/external/meta-iot-cloud/recipes-aws/python/python3-gg-group-setup_0.5.3.bb
@@ -0,0 +1,10 @@
+inherit setuptools3 update-alternatives
+require python-gg-group-setup.inc
+
+ALTERNATIVE_${PN} = "\
+ gg_group_setup \
+"
+
+ALTERNATIVE_LINK_NAME[gg_group_setup] = "${bindir}/gg_group_setup"
+
+ALTERNATIVE_PRIORITY = "30"
diff --git a/external/meta-iot-cloud/recipes-aws/python/python3-s3transfer_0.2.1.bb b/external/meta-iot-cloud/recipes-aws/python/python3-s3transfer_0.2.1.bb
new file mode 100644
index 00000000..d74a5916
--- /dev/null
+++ b/external/meta-iot-cloud/recipes-aws/python/python3-s3transfer_0.2.1.bb
@@ -0,0 +1,8 @@
+inherit setuptools3
+require python-s3transfer.inc
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-multiprocessing \
+"
+
+BBCLASSEXTEND = "native nativesdk"