summaryrefslogtreecommitdiffstats
path: root/external/meta-iot-cloud/recipes-azure/python/python3-azure-iot-device_2.1.1.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/meta-iot-cloud/recipes-azure/python/python3-azure-iot-device_2.1.1.bb
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/meta-iot-cloud/recipes-azure/python/python3-azure-iot-device_2.1.1.bb')
-rw-r--r--external/meta-iot-cloud/recipes-azure/python/python3-azure-iot-device_2.1.1.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/external/meta-iot-cloud/recipes-azure/python/python3-azure-iot-device_2.1.1.bb b/external/meta-iot-cloud/recipes-azure/python/python3-azure-iot-device_2.1.1.bb
new file mode 100644
index 00000000..7f2f094e
--- /dev/null
+++ b/external/meta-iot-cloud/recipes-azure/python/python3-azure-iot-device_2.1.1.bb
@@ -0,0 +1,33 @@
+SUMMARY = "Microsoft Azure IoT Device Library"
+AUTHOR = "Microsoft Corporation"
+HOMEPAGE = "https://github.com/Azure/azure-iot-sdk-python/tree/master/azure-iot-device"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-janus \
+ ${PYTHON_PN}-paho-mqtt \
+ ${PYTHON_PN}-pysocks \
+ ${PYTHON_PN}-requests \
+ ${PYTHON_PN}-requests-unixsocket \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-transitions \
+ ${PYTHON_PN}-urllib3 \
+"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-asyncio \
+ ${PYTHON_PN}-crypt \
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-multiprocessing \
+ ${PYTHON_PN}-netclient \
+"
+
+PR = "r0"
+
+SRC_URI[sha256sum] = "6186c9be8c25917a29ac9f432b484d5c28e428ec83a919926c77b0472d36abc7"