summaryrefslogtreecommitdiffstats
path: root/external/meta-iot-cloud/recipes-azure/umock-c
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/meta-iot-cloud/recipes-azure/umock-c
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/meta-iot-cloud/recipes-azure/umock-c')
-rw-r--r--external/meta-iot-cloud/recipes-azure/umock-c/umock-c.inc22
-rw-r--r--external/meta-iot-cloud/recipes-azure/umock-c/umock-c_1.1.19.bb14
2 files changed, 36 insertions, 0 deletions
diff --git a/external/meta-iot-cloud/recipes-azure/umock-c/umock-c.inc b/external/meta-iot-cloud/recipes-azure/umock-c/umock-c.inc
new file mode 100644
index 00000000..9d1bf079
--- /dev/null
+++ b/external/meta-iot-cloud/recipes-azure/umock-c/umock-c.inc
@@ -0,0 +1,22 @@
+inherit cmake
+
+DEPENDS = "\
+ azure-macro-utils-c \
+"
+
+S = "${WORKDIR}/git"
+B = "${WORKDIR}/build"
+
+EXTRA_OECMAKE = "\
+ -Duse_installed_dependencies:BOOL=ON \
+"
+
+sysroot_stage_all_append () {
+ sysroot_stage_dir ${D}${exec_prefix}/cmake ${SYSROOT_DESTDIR}${exec_prefix}/cmake
+}
+
+FILES_${PN}-dev += "\
+ ${exec_prefix}/cmake \
+"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/external/meta-iot-cloud/recipes-azure/umock-c/umock-c_1.1.19.bb b/external/meta-iot-cloud/recipes-azure/umock-c/umock-c_1.1.19.bb
new file mode 100644
index 00000000..6c9dcc95
--- /dev/null
+++ b/external/meta-iot-cloud/recipes-azure/umock-c/umock-c_1.1.19.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "umock_c is a C mocking library."
+HOMEPAGE = "https://github.com/Azure/umock-c"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4f9c2c296f77b3096b6c11a16fa7c66e"
+
+SRC_URI = "\
+ git://github.com/Azure/umock-c.git \
+"
+
+SRCREV = "504193e65d1c2f6eb50c15357167600a296df7ff"
+
+PR = "r0"
+
+require ${BPN}.inc