summaryrefslogtreecommitdiffstats
path: root/external/meta-iot-cloud/recipes-connectivity/rclone/rclone_1.50.2.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/meta-iot-cloud/recipes-connectivity/rclone/rclone_1.50.2.bb
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/meta-iot-cloud/recipes-connectivity/rclone/rclone_1.50.2.bb')
-rw-r--r--external/meta-iot-cloud/recipes-connectivity/rclone/rclone_1.50.2.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/external/meta-iot-cloud/recipes-connectivity/rclone/rclone_1.50.2.bb b/external/meta-iot-cloud/recipes-connectivity/rclone/rclone_1.50.2.bb
new file mode 100644
index 00000000..ebb85e9b
--- /dev/null
+++ b/external/meta-iot-cloud/recipes-connectivity/rclone/rclone_1.50.2.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Rclone - rsync for cloud storage. "
+DESCRIPTION = "Sync files to and from many cloud storage providers like AWS S3, Google Cloud, Azure and many more"
+AUTHOR = "Nishant Poorswani <nishantpoorswani@gmail.com>"
+HOMEPAGE = "https://rclone.org/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://src/github.com/rclone/rclone/COPYING;md5=bed161b82a1ecab65ff7ba3c3b960439"
+
+RDEPENDS_${PN}-dev = "\
+ bash \
+ python3-core \
+"
+
+inherit go
+
+GO_IMPORT = "github.com/rclone/rclone"
+
+SRC_URI = "git://${GO_IMPORT};branch=v1.50-fixes;tag=v${PV}"
+
+PR = "r0"
+
+do_install_prepend(){
+ rm -f ${B}/${GO_BUILD_BINDIR}/gen
+ rm -f ${B}/${GO_BUILD_BINDIR}/test_all
+ rm -f ${B}/${GO_BUILD_BINDIR}/test_vfs
+}