summaryrefslogtreecommitdiffstats
path: root/external/meta-iot-cloud/recipes-connectivity/restic/restic_0.9.6.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/meta-iot-cloud/recipes-connectivity/restic/restic_0.9.6.bb
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/meta-iot-cloud/recipes-connectivity/restic/restic_0.9.6.bb')
-rw-r--r--external/meta-iot-cloud/recipes-connectivity/restic/restic_0.9.6.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/external/meta-iot-cloud/recipes-connectivity/restic/restic_0.9.6.bb b/external/meta-iot-cloud/recipes-connectivity/restic/restic_0.9.6.bb
new file mode 100644
index 00000000..f094cd84
--- /dev/null
+++ b/external/meta-iot-cloud/recipes-connectivity/restic/restic_0.9.6.bb
@@ -0,0 +1,18 @@
+SUMMARY = "restic is a backup program that is fast, efficient and secure."
+DESCRIPTION = "Restic can backup and sync data to AWS S3, Google Cloud, Azure, SFTP servers and many more"
+AUTHOR = "Nishant Poorswani <nishantpoorswani@gmail.com>"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://src/github.com/restic/restic/LICENSE;md5=d267ffee32f3f73928409ee59c2c9667"
+
+inherit go
+
+GO_IMPORT = "github.com/restic/restic"
+
+SRC_URI = "git://${GO_IMPORT};tag=v${PV}"
+
+PR = "r0"
+
+do_install_prepend(){
+ rm -f ${B}/${GO_BUILD_BINDIR}/build-release-binaries
+ rm -f ${B}/${GO_BUILD_BINDIR}/prepare-release
+}