summaryrefslogtreecommitdiffstats
path: root/external/meta-iot-cloud/recipes-devtools/python/python3-argcomplete_1.9.4.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/meta-iot-cloud/recipes-devtools/python/python3-argcomplete_1.9.4.bb
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/meta-iot-cloud/recipes-devtools/python/python3-argcomplete_1.9.4.bb')
-rw-r--r--external/meta-iot-cloud/recipes-devtools/python/python3-argcomplete_1.9.4.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/external/meta-iot-cloud/recipes-devtools/python/python3-argcomplete_1.9.4.bb b/external/meta-iot-cloud/recipes-devtools/python/python3-argcomplete_1.9.4.bb
new file mode 100644
index 00000000..0acfa380
--- /dev/null
+++ b/external/meta-iot-cloud/recipes-devtools/python/python3-argcomplete_1.9.4.bb
@@ -0,0 +1,14 @@
+inherit pypi setuptools3 update-alternatives
+require python-argcomplete.inc
+
+ALTERNATIVE_${PN} = "\
+ activate-global-python-argcomplete \
+ python-argcomplete-check-easy-install-script \
+ register-python-argcomplete \
+"
+
+ALTERNATIVE_LINK_NAME[activate-global-python-argcomplete] = "${bindir}/activate-global-python-argcomplete"
+ALTERNATIVE_LINK_NAME[python-argcomplete-check-easy-install-script] = "${bindir}/python-argcomplete-check-easy-install-script"
+ALTERNATIVE_LINK_NAME[register-python-argcomplete] = "${bindir}/register-python-argcomplete"
+
+ALTERNATIVE_PRIORITY = "30"