summaryrefslogtreecommitdiffstats
path: root/external/meta-iot-cloud/recipes-devtools/python/python3-transitions_0.8.1.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/meta-iot-cloud/recipes-devtools/python/python3-transitions_0.8.1.bb
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/meta-iot-cloud/recipes-devtools/python/python3-transitions_0.8.1.bb')
-rw-r--r--external/meta-iot-cloud/recipes-devtools/python/python3-transitions_0.8.1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/external/meta-iot-cloud/recipes-devtools/python/python3-transitions_0.8.1.bb b/external/meta-iot-cloud/recipes-devtools/python/python3-transitions_0.8.1.bb
new file mode 100644
index 00000000..107e98c6
--- /dev/null
+++ b/external/meta-iot-cloud/recipes-devtools/python/python3-transitions_0.8.1.bb
@@ -0,0 +1,23 @@
+SUMMARY = "A lightweight, object-oriented Python state machine implementation with many extensions."
+AUTHOR = "Tal Yarkoni"
+HOMEPAGE = "http://github.com/pytransitions/transitions"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8734a2c2e13bbf9c2fd1b6cb64af8219"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-six \
+"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-asyncio \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-typing \
+"
+
+PR = "r0"
+
+SRC_URI[sha256sum] = "2b8cf2078ed189ffbb0f29421798d7a63ff0d7823682a0d69c01bd8240363cac"