summaryrefslogtreecommitdiffstats
path: root/external/meta-iot-cloud/recipes-node-red/node-red/node-red_1.0.2.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/meta-iot-cloud/recipes-node-red/node-red/node-red_1.0.2.bb
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/meta-iot-cloud/recipes-node-red/node-red/node-red_1.0.2.bb')
-rw-r--r--external/meta-iot-cloud/recipes-node-red/node-red/node-red_1.0.2.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/external/meta-iot-cloud/recipes-node-red/node-red/node-red_1.0.2.bb b/external/meta-iot-cloud/recipes-node-red/node-red/node-red_1.0.2.bb
new file mode 100644
index 00000000..b627e742
--- /dev/null
+++ b/external/meta-iot-cloud/recipes-node-red/node-red/node-red_1.0.2.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "Node-RED"
+HOMEPAGE = "http://nodered.org"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d6f37569f5013072e9490d2194d10ae6"
+
+inherit npm
+
+PR = "r0"
+
+SRC_URI = "\
+ npm://registry.npmjs.org;package=${BPN};version=${PV} \
+ npmsw://${THISDIR}/${BPN}/npm-shrinkwrap.json \
+ file://${BPN}.service \
+"
+
+S = "${WORKDIR}/npm"
+
+do_install_append() {
+ # Service
+ install -d ${D}${systemd_unitdir}/system/
+ install -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_unitdir}/system/
+
+ # Remove hardware specific files
+ rm ${D}/${bindir}/${BPN}-pi
+ rm -rf ${D}/${libdir}/node_modules/${BPN}/bin
+}
+
+inherit systemd
+
+SYSTEMD_AUTO_ENABLE = "enable"
+SYSTEMD_SERVICE_${PN} = "${BPN}.service"
+
+FILES_${PN} += "\
+ ${systemd_unitdir} \
+"