summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-gnome/recipes-kernel/sysprof/files/0001-meson.build-do-not-hardcode-linux-as-host_machine-.s.patch
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/meta-openembedded/meta-gnome/recipes-kernel/sysprof/files/0001-meson.build-do-not-hardcode-linux-as-host_machine-.s.patch
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/meta-openembedded/meta-gnome/recipes-kernel/sysprof/files/0001-meson.build-do-not-hardcode-linux-as-host_machine-.s.patch')
-rw-r--r--external/meta-openembedded/meta-gnome/recipes-kernel/sysprof/files/0001-meson.build-do-not-hardcode-linux-as-host_machine-.s.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/external/meta-openembedded/meta-gnome/recipes-kernel/sysprof/files/0001-meson.build-do-not-hardcode-linux-as-host_machine-.s.patch b/external/meta-openembedded/meta-gnome/recipes-kernel/sysprof/files/0001-meson.build-do-not-hardcode-linux-as-host_machine-.s.patch
new file mode 100644
index 00000000..23548922
--- /dev/null
+++ b/external/meta-openembedded/meta-gnome/recipes-kernel/sysprof/files/0001-meson.build-do-not-hardcode-linux-as-host_machine-.s.patch
@@ -0,0 +1,42 @@
+From 43c39b5685445242d071b3706af2903efa508b4a Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex.kanavin@gmail.com>
+Date: Tue, 14 Jan 2020 12:58:27 +0100
+Subject: [PATCH] meson.build: do not hardcode 'linux' as
+ host_machine().system() value
+
+In some build environmets such as OpenEmbedded this can be 'linux-gnueabi'
+or otherwise not exactly 'linux'.
+
+Upstream-Status: Pending
+Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+---
+ src/libsysprof/meson.build | 2 +-
+ src/tools/meson.build | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/libsysprof/meson.build b/src/libsysprof/meson.build
+index 3449961..3c2d186 100644
+--- a/src/libsysprof/meson.build
++++ b/src/libsysprof/meson.build
+@@ -84,7 +84,7 @@ libsysprof_deps = [
+ polkit_dep,
+ ]
+
+-if host_machine.system() == 'linux'
++if host_machine.system().contains('linux')
+ libsysprof_public_sources += [
+ 'sysprof-memory-source.c',
+ 'sysprof-perf-counter.c',
+diff --git a/src/tools/meson.build b/src/tools/meson.build
+index 670052a..3fb7f0c 100644
+--- a/src/tools/meson.build
++++ b/src/tools/meson.build
+@@ -2,7 +2,7 @@ tools_deps = [
+ libsysprof_capture_dep,
+ ]
+
+-if get_option('libsysprof') and host_machine.system() == 'linux'
++if get_option('libsysprof') and host_machine.system().contains('linux')
+ polkit_agent_dep = dependency('polkit-agent-1')
+ sysprof_cli = executable('sysprof-cli', 'sysprof-cli.c',
+ dependencies: tools_deps + [libsysprof_dep, polkit_dep, polkit_agent_dep],