summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-gnome/recipes-kernel/sysprof/sysprof_3.34.1.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/meta-openembedded/meta-gnome/recipes-kernel/sysprof/sysprof_3.34.1.bb
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/meta-openembedded/meta-gnome/recipes-kernel/sysprof/sysprof_3.34.1.bb')
-rw-r--r--external/meta-openembedded/meta-gnome/recipes-kernel/sysprof/sysprof_3.34.1.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/external/meta-openembedded/meta-gnome/recipes-kernel/sysprof/sysprof_3.34.1.bb b/external/meta-openembedded/meta-gnome/recipes-kernel/sysprof/sysprof_3.34.1.bb
new file mode 100644
index 00000000..ad69ab68
--- /dev/null
+++ b/external/meta-openembedded/meta-gnome/recipes-kernel/sysprof/sysprof_3.34.1.bb
@@ -0,0 +1,37 @@
+SUMMARY = "System-wide Performance Profiler for Linux"
+HOMEPAGE = "http://www.sysprof.com"
+LICENSE = "GPLv3+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
+ file://src/sysprof/sysprof-application.c;endline=17;md5=a3de8df3b0f8876dd01e1388d2d4b607"
+
+GNOMEBASEBUILDCLASS = "meson"
+inherit gnomebase gettext systemd upstream-version-is-even gsettings mime mime-xdg
+
+DEPENDS += "glib-2.0 libxml2-native glib-2.0-native"
+
+SRC_URI[archive.md5sum] = "cc32455277b31afb1965d627ae3e3629"
+SRC_URI[archive.sha256sum] = "844bbb8d8b65071b3bca96f8e921319ceef81f2d2c51fcc9da63a4b355c893d0"
+SRC_URI += "file://0001-sysprof-Define-NT_GNU_BUILD_ID-if-undefined.patch \
+ file://0001-meson.build-do-not-hardcode-linux-as-host_machine-.s.patch \
+ file://0001-libsysprof-ui-Rename-environ-to-sys_environ.patch \
+ "
+
+PACKAGECONFIG ?= "sysprofd libsysprof ${@bb.utils.contains_any('DISTRO_FEATURES', '${GTK3DISTROFEATURES}', 'gtk', '', d)}"
+PACKAGECONFIG[gtk] = "-Denable_gtk=true,-Denable_gtk=false,gtk+3 libdazzle"
+PACKAGECONFIG[sysprofd] = "-Dwith_sysprofd=bundled,-Dwith_sysprofd=none,polkit"
+PACKAGECONFIG[libsysprof] = "-Dlibsysprof=true,-Dlibsysprof=false,polkit"
+
+# Enablig this requries yelp
+EXTRA_OEMESON += "-Dhelp=false -Dsystemdunitdir=${systemd_unitdir}/system"
+
+SOLIBS = ".so"
+FILES_SOLIBSDEV = ""
+
+SYSTEMD_SERVICE_${PN} = "${@bb.utils.contains('PACKAGECONFIG', 'sysprofd', 'sysprof2.service sysprof3.service', '', d)}"
+
+FILES_${PN} += " \
+ ${datadir}/dbus-1/system-services \
+ ${datadir}/dbus-1/system.d \
+ ${datadir}/dbus-1/interfaces \
+ ${datadir}/metainfo \
+ "