summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-initramfs/recipes-bsp
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/meta-openembedded/meta-initramfs/recipes-bsp
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/meta-openembedded/meta-initramfs/recipes-bsp')
-rw-r--r--external/meta-openembedded/meta-initramfs/recipes-bsp/images/initramfs-debug-image.bb22
-rw-r--r--external/meta-openembedded/meta-initramfs/recipes-bsp/images/initramfs-kexecboot-image.bb28
-rw-r--r--external/meta-openembedded/meta-initramfs/recipes-bsp/images/initramfs-kexecboot-klibc-image.bb12
-rw-r--r--external/meta-openembedded/meta-initramfs/recipes-bsp/initrdscripts/files/init-debug.sh31
-rw-r--r--external/meta-openembedded/meta-initramfs/recipes-bsp/initrdscripts/initramfs-debug_1.0.bb14
-rw-r--r--external/meta-openembedded/meta-initramfs/recipes-bsp/kexecboot/files/0001-kexecboot-Use-new-reboot-API-with-klibc.patch42
-rw-r--r--external/meta-openembedded/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb4
7 files changed, 45 insertions, 108 deletions
diff --git a/external/meta-openembedded/meta-initramfs/recipes-bsp/images/initramfs-debug-image.bb b/external/meta-openembedded/meta-initramfs/recipes-bsp/images/initramfs-debug-image.bb
deleted file mode 100644
index be7350ad..00000000
--- a/external/meta-openembedded/meta-initramfs/recipes-bsp/images/initramfs-debug-image.bb
+++ /dev/null
@@ -1,22 +0,0 @@
-# Simple initramfs image. Mostly used for live images.
-DESCRIPTION = "Small image capable of booting a device. The kernel includes \
-the Minimal RAM-based Initial Root Filesystem (initramfs), which one can use \
-to check the hardware efficiently."
-
-PACKAGE_INSTALL = "initramfs-debug busybox base-passwd ${ROOTFS_BOOTSTRAP_INSTALL}"
-
-# Do not pollute the initrd image with rootfs features
-IMAGE_FEATURES = ""
-
-export IMAGE_BASENAME = "initramfs-debug-image"
-IMAGE_LINGUAS = ""
-
-LICENSE = "MIT"
-
-IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
-inherit core-image
-
-IMAGE_ROOTFS_SIZE = "8192"
-IMAGE_ROOTFS_EXTRA_SPACE = "0"
-
-BAD_RECOMMENDATIONS += "busybox-syslog"
diff --git a/external/meta-openembedded/meta-initramfs/recipes-bsp/images/initramfs-kexecboot-image.bb b/external/meta-openembedded/meta-initramfs/recipes-bsp/images/initramfs-kexecboot-image.bb
deleted file mode 100644
index 2573eb48..00000000
--- a/external/meta-openembedded/meta-initramfs/recipes-bsp/images/initramfs-kexecboot-image.bb
+++ /dev/null
@@ -1,28 +0,0 @@
-SUMMARY = "Initramfs image for kexecboot kernel"
-DESCRIPTION = "This image provides kexecboot (linux as bootloader) and helpers."
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
-
-inherit image
-
-IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
-
-# avoid circular dependencies
-EXTRA_IMAGEDEPENDS = ""
-KERNELDEPMODDEPEND = ""
-
-# We really need just kexecboot, kexec and ubiattach
-IMAGE_INSTALL = "kexecboot kexec mtd-utils-ubifs"
-
-# Do not pollute the initrd image with rootfs features
-IMAGE_FEATURES = ""
-
-IMAGE_LINGUAS = ""
-
-FEED_DEPLOYDIR_BASE_URI = ""
-LDCONFIGDEPEND = ""
-IMAGE_ROOTFS_EXTRA_SPACE = "0"
-
-# disable runtime dependency on run-postinsts -> update-rc.d
-ROOTFS_BOOTSTRAP_INSTALL = ""
-
diff --git a/external/meta-openembedded/meta-initramfs/recipes-bsp/images/initramfs-kexecboot-klibc-image.bb b/external/meta-openembedded/meta-initramfs/recipes-bsp/images/initramfs-kexecboot-klibc-image.bb
deleted file mode 100644
index 3a8d9f74..00000000
--- a/external/meta-openembedded/meta-initramfs/recipes-bsp/images/initramfs-kexecboot-klibc-image.bb
+++ /dev/null
@@ -1,12 +0,0 @@
-require initramfs-kexecboot-image.bb
-
-SUMMARY = "Initramfs image for kexecboot kernel (klibc-static binaries)"
-
-# We really need just kexecboot, kexec and ubiattach
-# statically compiled against klibc
-IMAGE_INSTALL = "kexecboot-klibc kexec-klibc ubiattach-klibc"
-
-python () {
- if d.getVar('TARGET_ARCH') == "nios2":
- raise bb.parse.SkipRecipe("'nios2' not supported arch")
-}
diff --git a/external/meta-openembedded/meta-initramfs/recipes-bsp/initrdscripts/files/init-debug.sh b/external/meta-openembedded/meta-initramfs/recipes-bsp/initrdscripts/files/init-debug.sh
deleted file mode 100644
index 7edbd70c..00000000
--- a/external/meta-openembedded/meta-initramfs/recipes-bsp/initrdscripts/files/init-debug.sh
+++ /dev/null
@@ -1,31 +0,0 @@
-#!/bin/sh
-
-PATH=/sbin:/bin:/usr/sbin:/usr/bin
-
-do_mount_fs() {
- grep -q "$1" /proc/filesystems || return
- test -d "$2" || mkdir -p "$2"
- mount -t "$1" "$1" "$2"
-}
-
-do_mknod() {
- test -e "$1" || mknod "$1" "$2" "$3" "$4"
-}
-
-mkdir -p /proc
-mount -t proc proc /proc
-
-do_mount_fs sysfs /sys
-do_mount_fs debugfs /sys/kernel/debug
-do_mount_fs devtmpfs /dev
-do_mount_fs devpts /dev/pts
-do_mount_fs tmpfs /dev/shm
-
-mkdir -p /run
-mkdir -p /var/run
-
-do_mknod /dev/console c 5 1
-do_mknod /dev/null c 1 3
-do_mknod /dev/zero c 1 5
-
-exec sh </dev/console >/dev/console 2>/dev/console
diff --git a/external/meta-openembedded/meta-initramfs/recipes-bsp/initrdscripts/initramfs-debug_1.0.bb b/external/meta-openembedded/meta-initramfs/recipes-bsp/initrdscripts/initramfs-debug_1.0.bb
deleted file mode 100644
index 667690f8..00000000
--- a/external/meta-openembedded/meta-initramfs/recipes-bsp/initrdscripts/initramfs-debug_1.0.bb
+++ /dev/null
@@ -1,14 +0,0 @@
-SUMMARY = "Extremely basic live image init script"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
-SRC_URI = "file://init-debug.sh"
-
-S = "${WORKDIR}"
-
-do_install() {
- install -m 0755 ${WORKDIR}/init-debug.sh ${D}/init
-}
-
-inherit allarch
-
-FILES_${PN} += " /init "
diff --git a/external/meta-openembedded/meta-initramfs/recipes-bsp/kexecboot/files/0001-kexecboot-Use-new-reboot-API-with-klibc.patch b/external/meta-openembedded/meta-initramfs/recipes-bsp/kexecboot/files/0001-kexecboot-Use-new-reboot-API-with-klibc.patch
new file mode 100644
index 00000000..52d622a2
--- /dev/null
+++ b/external/meta-openembedded/meta-initramfs/recipes-bsp/kexecboot/files/0001-kexecboot-Use-new-reboot-API-with-klibc.patch
@@ -0,0 +1,42 @@
+From a6d1678379df6142a68cc9bb76dae540a31b8fdb Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Thu, 14 Mar 2019 23:47:50 -0700
+Subject: [PATCH] kexecboot: Use new reboot() API with klibc
+
+Klibc has changed this API in
+https://git.kernel.org/pub/scm/libs/klibc/klibc.git/commit/?id=6b621b8705ce5901dcf49607c8a3523c9e521901
+
+therefore adopt the code
+
+Upstream-Status: Pending
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/kexecboot.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/kexecboot.c b/src/kexecboot.c
+index cf49b40..c785fce 100644
+--- a/src/kexecboot.c
++++ b/src/kexecboot.c
+@@ -857,7 +857,7 @@ int process_ctx_menu(struct params_t *params, int action) {
+ #else
+ sync();
+ /* if ( -1 == reboot(LINUX_REBOOT_CMD_RESTART) ) { */
+- if ( -1 == reboot(RB_AUTOBOOT) ) {
++ if ( -1 == reboot(RB_AUTOBOOT, NULL) ) {
+ log_msg(lg, "Can't initiate reboot: %s", ERRMSG);
+ }
+ #endif
+@@ -874,7 +874,7 @@ int process_ctx_menu(struct params_t *params, int action) {
+ #else
+ sync();
+ /* if ( -1 == reboot(LINUX_REBOOT_CMD_POWER_OFF) ) { */
+- if ( -1 == reboot(RB_POWER_OFF) ) {
++ if ( -1 == reboot(RB_POWER_OFF, NULL) ) {
+ log_msg(lg, "Can't initiate shutdown: %s", ERRMSG);
+ }
+ #endif
+--
+2.21.0
+
diff --git a/external/meta-openembedded/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb b/external/meta-openembedded/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb
index 6d79e8f8..ed3dece3 100644
--- a/external/meta-openembedded/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb
+++ b/external/meta-openembedded/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb
@@ -6,7 +6,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
PV = "0.6+git${SRCPV}"
S = "${WORKDIR}/git"
SRC_URI = "git://github.com/kexecboot/kexecboot.git"
-SRCREV = "4c01d6960aa6a9d03675605062469ab777fa2b01"
+SRC_URI_append_libc-klibc = " file://0001-kexecboot-Use-new-reboot-API-with-klibc.patch "
+
+SRCREV = "5a5e04be206140059f42ac786d424da1afaa04b6"
inherit autotools
EXTRA_OECONF = "--enable-textui --enable-delay=2 --enable-evdev-rate=1000,250"