summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-oe/recipes-support/opensc
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/meta-openembedded/meta-oe/recipes-support/opensc
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/meta-openembedded/meta-oe/recipes-support/opensc')
-rw-r--r--external/meta-openembedded/meta-oe/recipes-support/opensc/opensc/0001-Fixed-gcc-8-compilation-errors-1353.patch73
-rw-r--r--external/meta-openembedded/meta-oe/recipes-support/opensc/opensc_0.20.0.bb (renamed from external/meta-openembedded/meta-oe/recipes-support/opensc/opensc_0.18.0.bb)29
2 files changed, 15 insertions, 87 deletions
diff --git a/external/meta-openembedded/meta-oe/recipes-support/opensc/opensc/0001-Fixed-gcc-8-compilation-errors-1353.patch b/external/meta-openembedded/meta-oe/recipes-support/opensc/opensc/0001-Fixed-gcc-8-compilation-errors-1353.patch
deleted file mode 100644
index 48d83275..00000000
--- a/external/meta-openembedded/meta-oe/recipes-support/opensc/opensc/0001-Fixed-gcc-8-compilation-errors-1353.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-From 87857d5cae7db94fdd776904886392b1e86053bd Mon Sep 17 00:00:00 2001
-From: Florian Bezdeka <1119693+fbezdeka@users.noreply.github.com>
-Date: Fri, 18 May 2018 18:54:56 +0200
-Subject: [PATCH] Fixed gcc 8 compilation errors (#1353)
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-The following errors occured during a compilation using gcc 8:
-
-In function »gids_create_file.constprop«,
- inserted by »gids_save_certificate.isra.8« beicard-gids.c:1548:7:
-card-gids.c:465:2: Error: »strncpy« output may be truncated copying 8 bytes from a string of length 8 [-Werror=stringop-truncation]
- strncpy(record->filename, filename, 8);
- ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-
-pkcs15-oberthur.c: In function »sc_pkcs15emu_oberthur_add_prvkey«:
-pkcs15-oberthur.c:741:5: Error: »strncpy« output may be truncated copying 254 bytes from a string of length 254 [-Werror=stringop-truncation]
- strncpy(kobj.label, objs[ii]->label, sizeof(kobj.label) - 1);
- ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-
-Upstream-Status: Backport [https://github.com/OpenSC/OpenSC/pull/1353]
-Signed-off-by Khem Raj <raj.khem@gmail.com>
----
- src/libopensc/card-gids.c | 3 ++-
- src/libopensc/pkcs15-oberthur.c | 3 ++-
- 2 files changed, 4 insertions(+), 2 deletions(-)
-
-diff --git a/src/libopensc/card-gids.c b/src/libopensc/card-gids.c
-index fc5d2a7..ac3e579 100644
---- a/src/libopensc/card-gids.c
-+++ b/src/libopensc/card-gids.c
-@@ -33,6 +33,7 @@ Some features are undocumented like the format used to store certificates. They
-
- #include <stdlib.h>
- #include <string.h>
-+#include "../common/compat_strlcpy.h"
-
- #ifdef ENABLE_OPENSSL
- /* openssl only needed for card administration */
-@@ -462,7 +463,7 @@ static int gids_create_file(sc_card_t *card, char* directory, char* filename) {
- memset(masterfilebuffer + offset, 0, sizeof(gids_mf_record_t));
- record = (gids_mf_record_t*) (masterfilebuffer + offset);
- strncpy(record->directory, directory, 8);
-- strncpy(record->filename, filename, 8);
-+ strlcpy(record->filename, filename, sizeof(record->filename));
- record->fileIdentifier = fileIdentifier;
- record->dataObjectIdentifier = dataObjectIdentifier;
-
-diff --git a/src/libopensc/pkcs15-oberthur.c b/src/libopensc/pkcs15-oberthur.c
-index 4f841ed..3415be7 100644
---- a/src/libopensc/pkcs15-oberthur.c
-+++ b/src/libopensc/pkcs15-oberthur.c
-@@ -29,6 +29,7 @@
- #include <stdlib.h>
- #include <string.h>
- #include <stdio.h>
-+#include "../common/compat_strlcpy.h"
-
- #include "pkcs15.h"
- #include "log.h"
-@@ -738,7 +739,7 @@ sc_pkcs15emu_oberthur_add_prvkey(struct sc_pkcs15_card *p15card,
- unsigned int id = path.value[path.len - 2] * 0x100 + path.value[path.len - 1];
-
- if (id == ccont.id_cert) {
-- strncpy(kobj.label, objs[ii]->label, sizeof(kobj.label) - 1);
-+ strlcpy(kobj.label, objs[ii]->label, sizeof(kobj.label));
- break;
- }
- }
---
-2.18.0
-
diff --git a/external/meta-openembedded/meta-oe/recipes-support/opensc/opensc_0.18.0.bb b/external/meta-openembedded/meta-oe/recipes-support/opensc/opensc_0.20.0.bb
index 45c931e7..a815980c 100644
--- a/external/meta-openembedded/meta-oe/recipes-support/opensc/opensc_0.18.0.bb
+++ b/external/meta-openembedded/meta-oe/recipes-support/opensc/opensc_0.20.0.bb
@@ -8,31 +8,30 @@ eID cards have also been confirmed to work."
HOMEPAGE = "http://www.opensc-project.org/opensc/"
SECTION = "System Environment/Libraries"
-
-SRC_URI = "https://snapshot.debian.org/archive/debian/20180521T101428Z/pool/main/o/opensc/opensc_0.18.0.orig.tar.gz \
- file://0001-Fixed-gcc-8-compilation-errors-1353.patch \
- "
-
-SRC_URI[md5sum] = "bce516f752e0db5327aa06cc0136fe27"
-SRC_URI[sha256sum] = "6ef62b00e8fdbe3e386c3ee25c2cadb56c1931ea42f1a11dce8c947f51b45033"
-
-DEPENDS = "openct pcsc-lite virtual/libiconv openssl"
-
LICENSE = "LGPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
-inherit autotools pkgconfig
+#v0.19.0
+SRCREV = "45e29056ccde422e70ed3585084a7f150c632515"
+SRC_URI = "git://github.com/OpenSC/OpenSC \
+ "
+DEPENDS = "virtual/libiconv openssl"
+
+S = "${WORKDIR}/git"
+inherit autotools pkgconfig bash-completion
-S = "${WORKDIR}/OpenSC-${PV}"
EXTRA_OECONF = " \
--disable-static \
- --enable-openct \
- --disable-pcsc \
--disable-ctapi \
--disable-doc \
"
EXTRA_OEMAKE = "DESTDIR=${D}"
+PACKAGECONFIG ??= "pcsc"
+
+PACKAGECONFIG[openct] = "--enable-openct,--disable-openct,openct"
+PACKAGECONFIG[pcsc] = "--enable-pcsc,--disable-pcsc,pcsc-lite,pcsc-lite pcsc-lite-lib"
+
RDEPENDS_${PN} = "readline"
FILES_${PN} += "\
@@ -45,3 +44,5 @@ FILES_${PN}-dev += "\
${libdir}/pkcs11/onepin-opensc-pkcs11.so \
${libdir}/pkcs11/pkcs11-spy.so \
"
+
+BBCLASSEXTEND = "native"