summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-oe/recipes-support/poco
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/meta-openembedded/meta-oe/recipes-support/poco
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/meta-openembedded/meta-oe/recipes-support/poco')
-rw-r--r--external/meta-openembedded/meta-oe/recipes-support/poco/poco/0001-riscv-Enable-double-operations-when-using-double-flo.patch28
-rw-r--r--external/meta-openembedded/meta-oe/recipes-support/poco/poco_1.9.4.bb (renamed from external/meta-openembedded/meta-oe/recipes-support/poco/poco_1.9.0.bb)6
2 files changed, 33 insertions, 1 deletions
diff --git a/external/meta-openembedded/meta-oe/recipes-support/poco/poco/0001-riscv-Enable-double-operations-when-using-double-flo.patch b/external/meta-openembedded/meta-oe/recipes-support/poco/poco/0001-riscv-Enable-double-operations-when-using-double-flo.patch
new file mode 100644
index 00000000..c0de32da
--- /dev/null
+++ b/external/meta-openembedded/meta-oe/recipes-support/poco/poco/0001-riscv-Enable-double-operations-when-using-double-flo.patch
@@ -0,0 +1,28 @@
+From 589a5442a841b156a1890bc2d26e7a5103e2f672 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Fri, 1 Nov 2019 17:53:50 -0700
+Subject: [PATCH] riscv: Enable double operations when using double float abi
+
+Upstream-Status: Submitted [https://github.com/pocoproject/poco/pull/2825]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ Foundation/src/utils.h | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/Foundation/src/utils.h b/Foundation/src/utils.h
+index 69cea1aca..ff7a5c9ce 100644
+--- a/Foundation/src/utils.h
++++ b/Foundation/src/utils.h
+@@ -63,7 +63,8 @@
+ defined(__SH4__) || defined(__alpha__) || \
+ defined(_MIPS_ARCH_MIPS32R2) || \
+ defined(__AARCH64EL__) || \
+- defined(nios2) || defined(__nios2) || defined(__nios2__)
++ defined(nios2) || defined(__nios2) || defined(__nios2__) || \
++ (defined(__riscv) && defined(__riscv_float_abi_double))
+ #define DOUBLE_CONVERSION_CORRECT_DOUBLE_OPERATIONS 1
+ #elif defined(_M_IX86) || defined(__i386__) || defined(__i386)
+ #if defined(_WIN32)
+--
+2.23.0
+
diff --git a/external/meta-openembedded/meta-oe/recipes-support/poco/poco_1.9.0.bb b/external/meta-openembedded/meta-oe/recipes-support/poco/poco_1.9.4.bb
index 258cc499..fcd52197 100644
--- a/external/meta-openembedded/meta-oe/recipes-support/poco/poco_1.9.0.bb
+++ b/external/meta-openembedded/meta-oe/recipes-support/poco/poco_1.9.4.bb
@@ -11,9 +11,12 @@ DEPENDS = "libpcre zlib"
SRC_URI = " \
git://github.com/pocoproject/poco.git;branch=poco-${PV} \
file://0001-Don-t-try-to-install-non-existing-Encodings-testsuit.patch \
+ file://0001-riscv-Enable-double-operations-when-using-double-flo.patch \
file://run-ptest \
"
-SRCREV = "daf00da73ab917e4d4581e3aa00c0ee61e0cc58b"
+SRCREV = "b95393dcc3640807838e8323b4e600e54d2e8116"
+
+UPSTREAM_CHECK_GITTAGREGEX = "poco-(?P<pver>\d+(\.\d+)+)"
S = "${WORKDIR}/git"
@@ -51,6 +54,7 @@ PACKAGECONFIG[SevenZip] = "-DENABLE_SEVENZIP=ON,-DENABLE_SEVENZIP=OFF"
EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=RelWithDebInfo -DPOCO_UNBUNDLED=ON \
-DZLIB_LIBRARY_RELEASE:STRING=z -DPCRE_LIBRARY:STRING=pcre \
+ -DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')} \
${@bb.utils.contains('PTEST_ENABLED', '1', '-DENABLE_TESTS=ON ', '', d)}"
# For the native build we want to use the bundled version