summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-oe/recipes-support/synergy/synergy_git.bb
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /external/meta-openembedded/meta-oe/recipes-support/synergy/synergy_git.bb
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'external/meta-openembedded/meta-oe/recipes-support/synergy/synergy_git.bb')
-rw-r--r--external/meta-openembedded/meta-oe/recipes-support/synergy/synergy_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/external/meta-openembedded/meta-oe/recipes-support/synergy/synergy_git.bb b/external/meta-openembedded/meta-oe/recipes-support/synergy/synergy_git.bb
new file mode 100644
index 00000000..f5518bd8
--- /dev/null
+++ b/external/meta-openembedded/meta-oe/recipes-support/synergy/synergy_git.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Synergy - control multiple computers with one keyboard and mouse"
+HOMEPAGE = "http://synergy-project.org"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=54c1fc8d8bb6776ae501acfb1585e9d6"
+LICENSE = "GPL-2.0-with-OpenSSL-exception"
+SECTION = "x11/utils"
+
+DEPENDS = "virtual/libx11 libxtst libxinerama curl openssl"
+
+# depends on virtual/libx11
+REQUIRED_DISTRO_FEATURES = "x11"
+
+SRC_URI = "git://github.com/symless/synergy-core;protocol=https;nobranch=1"
+
+# Version 1.10.1-stable
+SRCREV ?= "1b4c076127687aceac931d269e898beaac1cad9f"
+PV = "1.10.1+git${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+inherit cmake distro_features_check
+
+EXTRA_OECMAKE += "-DSYNERGY_BUILD_LEGACY_GUI=OFF"
+
+FILES_${PN} += "${datadir}/icons/hicolor"