summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-perl/recipes-extended/mime-construct
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /external/meta-openembedded/meta-perl/recipes-extended/mime-construct
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'external/meta-openembedded/meta-perl/recipes-extended/mime-construct')
-rw-r--r--external/meta-openembedded/meta-perl/recipes-extended/mime-construct/files/fix-mime-construct-help-return-value.patch39
-rw-r--r--external/meta-openembedded/meta-perl/recipes-extended/mime-construct/mime-construct_1.11.bb28
2 files changed, 67 insertions, 0 deletions
diff --git a/external/meta-openembedded/meta-perl/recipes-extended/mime-construct/files/fix-mime-construct-help-return-value.patch b/external/meta-openembedded/meta-perl/recipes-extended/mime-construct/files/fix-mime-construct-help-return-value.patch
new file mode 100644
index 00000000..5e4281d4
--- /dev/null
+++ b/external/meta-openembedded/meta-perl/recipes-extended/mime-construct/files/fix-mime-construct-help-return-value.patch
@@ -0,0 +1,39 @@
+From 2b9ed06850410d70371b31de5f131e484ba1c851 Mon Sep 17 00:00:00 2001
+From: Lu Chong <Chong.Lu@windriver.com>
+Date: Thu, 17 Oct 2013 16:06:04 +0800
+Subject: [PATCH] fix mime-construct --help return value
+
+Upstream-Status: Pending
+
+Signed-off-by: Lu Chong <Chong.Lu@windriver.com>
+
+---
+ mime-construct | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/mime-construct b/mime-construct
+index cad7d0e..707ed19 100755
+--- a/mime-construct
++++ b/mime-construct
+@@ -39,7 +39,7 @@ usage: $Me switch...
+
+ Global settings:
+ --debug turn debugging on
+- --help show this and then die
++ --help show this
+ --output don\'t mail, output to stdout (loses bcc info)
+ --subpart generate subpart rather than whole message (turns
+ on --output, changes other semantics a bit)
+@@ -150,7 +150,8 @@ sub xwarn {
+
+ sub usage {
+ xwarn @_ if @_;
+- die $Usage;
++ print $Usage;
++ exit 0;
+ }
+
+ sub init {
+--
+1.7.9.5
+
diff --git a/external/meta-openembedded/meta-perl/recipes-extended/mime-construct/mime-construct_1.11.bb b/external/meta-openembedded/meta-perl/recipes-extended/mime-construct/mime-construct_1.11.bb
new file mode 100644
index 00000000..501f3bf1
--- /dev/null
+++ b/external/meta-openembedded/meta-perl/recipes-extended/mime-construct/mime-construct_1.11.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Construct and optionally mail MIME messages"
+DESCRIPTION = "Constructs and (by default) mails MIME messages. \
+ It is entirely driven from the command line, it is \
+ designed to be used by other programs, or people who act \
+ like programs."
+HOMEPAGE = "http://search.cpan.org/~rosch/mime-construct/mime-construct"
+SECTION = "mail"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://debian/copyright;md5=5e2e5da619ac8ef8c84767ccc4656e96"
+
+SRC_URI = "${CPAN_MIRROR}/authors/id/R/RO/ROSCH/mime-construct-${PV}.tar.gz \
+ file://fix-mime-construct-help-return-value.patch \
+"
+
+SRC_URI[md5sum] = "73834ea780fbea81b89dbd9b2fb54f58"
+SRC_URI[sha256sum] = "4cd7bb61b51d41192d1498c1051aa6a4ccd75aeb09b71d2ec706a7084a4a9303"
+
+inherit cpan
+
+RDEPENDS_${PN} = "libmime-types-perl libproc-waitstat-perl msmtp \
+ perl-module-filehandle perl-module-mime-base64 perl-module-mime-quotedprint perl-module-posix \
+"
+
+do_install_append() {
+ #change the interpreter in file
+ sed -i -e "s|${STAGING_BINDIR_NATIVE}/perl-native/perl -w|${bindir}/env perl|g" \
+ ${D}/${bindir}/mime-construct
+}