summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-python/recipes-devtools/python/python3-automat_0.8.0.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/meta-openembedded/meta-python/recipes-devtools/python/python3-automat_0.8.0.bb
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/meta-openembedded/meta-python/recipes-devtools/python/python3-automat_0.8.0.bb')
-rw-r--r--external/meta-openembedded/meta-python/recipes-devtools/python/python3-automat_0.8.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/external/meta-openembedded/meta-python/recipes-devtools/python/python3-automat_0.8.0.bb b/external/meta-openembedded/meta-python/recipes-devtools/python/python3-automat_0.8.0.bb
new file mode 100644
index 00000000..f8981bcb
--- /dev/null
+++ b/external/meta-openembedded/meta-python/recipes-devtools/python/python3-automat_0.8.0.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Self-service finite-state machines for the programmer on the go"
+HOMEPAGE = "https://github.com/glyph/Automat"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4ad213bcca81688e94593e5f60c87477"
+
+SRC_URI[md5sum] = "47e980a48201a1dabe37fa11f0187013"
+SRC_URI[sha256sum] = "269a09dfb063a3b078983f4976d83f0a0d3e6e7aaf8e27d8df1095e09dc4a484"
+
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+
+SRC_URI_append = " \
+ file://0001-setup.py-remove-the-dependency-on-m2r.patch \
+"
+
+PYPI_PACKAGE = "Automat"
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-attrs \
+ ${PYTHON_PN}-six \
+"