summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-python/recipes-devtools/python/python3-can_3.3.2.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/meta-openembedded/meta-python/recipes-devtools/python/python3-can_3.3.2.bb
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/meta-openembedded/meta-python/recipes-devtools/python/python3-can_3.3.2.bb')
-rw-r--r--external/meta-openembedded/meta-python/recipes-devtools/python/python3-can_3.3.2.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/external/meta-openembedded/meta-python/recipes-devtools/python/python3-can_3.3.2.bb b/external/meta-openembedded/meta-python/recipes-devtools/python/python3-can_3.3.2.bb
new file mode 100644
index 00000000..698eaf5b
--- /dev/null
+++ b/external/meta-openembedded/meta-python/recipes-devtools/python/python3-can_3.3.2.bb
@@ -0,0 +1,26 @@
+SUMMARY = "Controller Area Network (CAN) interface module for Python"
+SECTION = "devel/python"
+LICENSE = "LGPLv3"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e6a600fd5e1d9cbde2d983680233ad02"
+
+SRC_URI[md5sum] = "b724553a330478270267380b4888a18e"
+SRC_URI[sha256sum] = "5fefb5c1e7e7f07faefc02c6eac79f9b58376f007048a04d8e7f325d48ec6b2e"
+
+PYPI_PACKAGE="python-can"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN}_class-target += "\
+ ${PYTHON_PN}-aenum \
+ ${PYTHON_PN}-ctypes \
+ ${PYTHON_PN}-codecs \
+ ${PYTHON_PN}-compression \
+ ${PYTHON_PN}-fcntl \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-misc \
+ ${PYTHON_PN}-netserver \
+ ${PYTHON_PN}-sqlite3 \
+ ${PYTHON_PN}-wrapt \
+"
+
+BBCLASSEXTEND = "native nativesdk"