summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-python/recipes-devtools/python/python3-dbussy_1.2.1.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/meta-openembedded/meta-python/recipes-devtools/python/python3-dbussy_1.2.1.bb
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/meta-openembedded/meta-python/recipes-devtools/python/python3-dbussy_1.2.1.bb')
-rw-r--r--external/meta-openembedded/meta-python/recipes-devtools/python/python3-dbussy_1.2.1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/external/meta-openembedded/meta-python/recipes-devtools/python/python3-dbussy_1.2.1.bb b/external/meta-openembedded/meta-python/recipes-devtools/python/python3-dbussy_1.2.1.bb
new file mode 100644
index 00000000..ac4b8c2a
--- /dev/null
+++ b/external/meta-openembedded/meta-python/recipes-devtools/python/python3-dbussy_1.2.1.bb
@@ -0,0 +1,22 @@
+SUMMARY = "language bindings for libdbus, for Python 3.5 or later"
+HOMEPAGE = "https://github.com/ldo/dbussy"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7"
+
+SRC_URI = "git://github.com/ldo/dbussy.git"
+
+SRCREV = "d0ec0223f3797e1612d835e71694a1083881149f"
+
+S = "${WORKDIR}/git"
+
+inherit distutils3
+
+RDEPENDS_${PN} += "\
+ python3-asyncio \
+ python3-core \
+ python3-ctypes \
+ python3-xml \
+"
+
+BBCLASSEXTEND = "native nativesdk"
+