summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-python/recipes-devtools/python/python3-protobuf_3.11.3.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/meta-openembedded/meta-python/recipes-devtools/python/python3-protobuf_3.11.3.bb
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/meta-openembedded/meta-python/recipes-devtools/python/python3-protobuf_3.11.3.bb')
-rw-r--r--external/meta-openembedded/meta-python/recipes-devtools/python/python3-protobuf_3.11.3.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/external/meta-openembedded/meta-python/recipes-devtools/python/python3-protobuf_3.11.3.bb b/external/meta-openembedded/meta-python/recipes-devtools/python/python3-protobuf_3.11.3.bb
new file mode 100644
index 00000000..30ea34e9
--- /dev/null
+++ b/external/meta-openembedded/meta-python/recipes-devtools/python/python3-protobuf_3.11.3.bb
@@ -0,0 +1,10 @@
+inherit setuptools3
+require python-protobuf.inc
+
+DEPENDS += "protobuf"
+DISTUTILS_BUILD_ARGS += "--cpp_implementation"
+DISTUTILS_INSTALL_ARGS += "--cpp_implementation"
+
+do_compile_prepend_class-native () {
+ export KOKORO_BUILD_NUMBER="1"
+}