summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-python/recipes-extended/pywbem
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/meta-openembedded/meta-python/recipes-extended/pywbem
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/meta-openembedded/meta-python/recipes-extended/pywbem')
-rw-r--r--external/meta-openembedded/meta-python/recipes-extended/pywbem/python-pywbem.inc9
-rw-r--r--external/meta-openembedded/meta-python/recipes-extended/pywbem/python-pywbem_0.11.0.bb13
-rw-r--r--external/meta-openembedded/meta-python/recipes-extended/pywbem/python3-pywbem_0.11.0.bb2
-rw-r--r--external/meta-openembedded/meta-python/recipes-extended/pywbem/python3-pywbem_0.15.0.bb9
4 files changed, 15 insertions, 18 deletions
diff --git a/external/meta-openembedded/meta-python/recipes-extended/pywbem/python-pywbem.inc b/external/meta-openembedded/meta-python/recipes-extended/pywbem/python-pywbem.inc
index 5151c33e..98508b0c 100644
--- a/external/meta-openembedded/meta-python/recipes-extended/pywbem/python-pywbem.inc
+++ b/external/meta-openembedded/meta-python/recipes-extended/pywbem/python-pywbem.inc
@@ -14,12 +14,15 @@ It also provides a Python provider interface, and is the fastest and easiest \
way to write providers on the planet."
HOMEPAGE = "http://pywbem.github.io"
LICENSE = "LGPLv2.1"
-LIC_FILES_CHKSUM = "file://pywbem/LICENSE.txt;md5=fbc093901857fcd118f065f900982c24"
-SRC_URI[md5sum] = "1465dfa92e4cbe558c773838b9b00711"
-SRC_URI[sha256sum] = "2a05f2c1a6ab4b08560a6da55fdaabd0f52f4d1e6df6e288b9ed927bf5c289ed"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=fbc093901857fcd118f065f900982c24"
inherit pypi
+SRCREV = "b3386b3bee8876d15f0745147c0b08937d8ab18e"
+PYPI_SRC_URI = "git://github.com/pywbem/pywbem;protocol=https;branch=stable_0.15"
+
+S = "${WORKDIR}/git"
+
DEPENDS += " \
${PYTHON_PN}-ply-native \
${PYTHON_PN}-pyyaml-native \
diff --git a/external/meta-openembedded/meta-python/recipes-extended/pywbem/python-pywbem_0.11.0.bb b/external/meta-openembedded/meta-python/recipes-extended/pywbem/python-pywbem_0.11.0.bb
deleted file mode 100644
index 74107490..00000000
--- a/external/meta-openembedded/meta-python/recipes-extended/pywbem/python-pywbem_0.11.0.bb
+++ /dev/null
@@ -1,13 +0,0 @@
-require python-pywbem.inc
-inherit setuptools
-
-DEPENDS += " \
- ${PYTHON_PN}-m2crypto-native \
- ${PYTHON_PN}-typing-native \
-"
-
-RDEPENDS_${PN}_class-target += "\
- ${PYTHON_PN}-argparse \
- ${PYTHON_PN}-m2crypto \
- ${PYTHON_PN}-subprocess \
-"
diff --git a/external/meta-openembedded/meta-python/recipes-extended/pywbem/python3-pywbem_0.11.0.bb b/external/meta-openembedded/meta-python/recipes-extended/pywbem/python3-pywbem_0.11.0.bb
deleted file mode 100644
index 6a35a874..00000000
--- a/external/meta-openembedded/meta-python/recipes-extended/pywbem/python3-pywbem_0.11.0.bb
+++ /dev/null
@@ -1,2 +0,0 @@
-require python-pywbem.inc
-inherit setuptools3
diff --git a/external/meta-openembedded/meta-python/recipes-extended/pywbem/python3-pywbem_0.15.0.bb b/external/meta-openembedded/meta-python/recipes-extended/pywbem/python3-pywbem_0.15.0.bb
new file mode 100644
index 00000000..abfb8d92
--- /dev/null
+++ b/external/meta-openembedded/meta-python/recipes-extended/pywbem/python3-pywbem_0.15.0.bb
@@ -0,0 +1,9 @@
+require python-pywbem.inc
+inherit setuptools3 update-alternatives
+
+ALTERNATIVE_${PN} = "mof_compiler pywbemcli wbemcli"
+ALTERNATIVE_TARGET[mof_compiler] = "${bindir}/mof_compiler"
+ALTERNATIVE_TARGET[pywbemcli] = "${bindir}/pywbemcli"
+ALTERNATIVE_TARGET[wbemcli] = "${bindir}/wbemcli"
+
+ALTERNATIVE_PRIORITY = "60"