summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-xfce/recipes-panel-plugins/notes
diff options
context:
space:
mode:
authorToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
committerToshikazuOhiwa <toshikazu_ohiwa@mail.toyota.co.jp>2020-03-30 09:24:26 +0900
commit5b80bfd7bffd4c20d80b7c70a7130529e9a755dd (patch)
treeb4bb18dcd1487dbf1ea8127e5671b7bb2eded033 /external/meta-openembedded/meta-xfce/recipes-panel-plugins/notes
parent706ad73eb02caf8532deaf5d38995bd258725cb8 (diff)
agl-basesystem
Diffstat (limited to 'external/meta-openembedded/meta-xfce/recipes-panel-plugins/notes')
-rw-r--r--external/meta-openembedded/meta-xfce/recipes-panel-plugins/notes/files/0001-main-status-icon.c-remove-deprecated-g_type_init.patch32
-rw-r--r--external/meta-openembedded/meta-xfce/recipes-panel-plugins/notes/files/01_fix_format-string.patch53
-rw-r--r--external/meta-openembedded/meta-xfce/recipes-panel-plugins/notes/xfce4-notes-plugin_1.8.1.bb20
3 files changed, 105 insertions, 0 deletions
diff --git a/external/meta-openembedded/meta-xfce/recipes-panel-plugins/notes/files/0001-main-status-icon.c-remove-deprecated-g_type_init.patch b/external/meta-openembedded/meta-xfce/recipes-panel-plugins/notes/files/0001-main-status-icon.c-remove-deprecated-g_type_init.patch
new file mode 100644
index 00000000..e1ede27c
--- /dev/null
+++ b/external/meta-openembedded/meta-xfce/recipes-panel-plugins/notes/files/0001-main-status-icon.c-remove-deprecated-g_type_init.patch
@@ -0,0 +1,32 @@
+From 0218e5ebf38f94d58b908fca451ba3789efa8899 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
+Date: Fri, 20 Sep 2013 23:09:25 +0200
+Subject: [PATCH] main-status-icon.c remove deprecated g_type_init
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+this file was auto created by valac and xfce-vala when creating tarball. So
+
+Upstream-Status: Inappropriate [other]
+
+Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
+---
+ src/main-status-icon.c | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/src/main-status-icon.c b/src/main-status-icon.c
+index c6d73f8..f7db773 100644
+--- a/src/main-status-icon.c
++++ b/src/main-status-icon.c
+@@ -290,7 +290,6 @@ gint _vala_main (char** args, int args_length1) {
+
+
+ int main (int argc, char ** argv) {
+- g_type_init ();
+ return _vala_main (argv, argc);
+ }
+
+--
+1.8.3.1
+
diff --git a/external/meta-openembedded/meta-xfce/recipes-panel-plugins/notes/files/01_fix_format-string.patch b/external/meta-openembedded/meta-xfce/recipes-panel-plugins/notes/files/01_fix_format-string.patch
new file mode 100644
index 00000000..8066df00
--- /dev/null
+++ b/external/meta-openembedded/meta-xfce/recipes-panel-plugins/notes/files/01_fix_format-string.patch
@@ -0,0 +1,53 @@
+Fix formatting strings when compiling with Wformat options
+
+Imported from debian
+
+--- a/lib/application.c
++++ b/lib/application.c
+@@ -352,7 +352,7 @@ static void xnp_application_update_notes
+ XfconfChannel* _tmp16_;
+ const gchar* _tmp17_;
+ _tmp9_ = _ ("Select notes path");
+- _tmp10_ = (GtkMessageDialog*) gtk_message_dialog_new (NULL, 0, GTK_MESSAGE_ERROR, GTK_BUTTONS_CLOSE, _tmp9_);
++ _tmp10_ = (GtkMessageDialog*) gtk_message_dialog_new (NULL, 0, GTK_MESSAGE_ERROR, GTK_BUTTONS_CLOSE, "%s", _tmp9_);
+ g_object_ref_sink (_tmp10_);
+ error_dialog = _tmp10_;
+ _tmp11_ = error_dialog;
+@@ -419,7 +419,7 @@ static void xnp_application_update_notes
+ XfconfChannel* _tmp35_;
+ const gchar* _tmp36_;
+ _tmp27_ = _ ("Select notes path");
+- _tmp28_ = (GtkMessageDialog*) gtk_message_dialog_new (NULL, 0, GTK_MESSAGE_ERROR, GTK_BUTTONS_CLOSE, _tmp27_);
++ _tmp28_ = (GtkMessageDialog*) gtk_message_dialog_new (NULL, 0, GTK_MESSAGE_ERROR, GTK_BUTTONS_CLOSE, "%s", _tmp27_);
+ g_object_ref_sink (_tmp28_);
+ error_dialog = _tmp28_;
+ _tmp29_ = error_dialog;
+@@ -2082,7 +2082,7 @@ static void xnp_application_delete_windo
+ gint _tmp9_;
+ _tmp3_ = window;
+ _tmp4_ = _ ("Are you sure you want to delete this group?");
+- _tmp5_ = (GtkMessageDialog*) gtk_message_dialog_new ((GtkWindow*) _tmp3_, GTK_DIALOG_DESTROY_WITH_PARENT, GTK_MESSAGE_QUESTION, GTK_BUTTONS_YES_NO, _tmp4_);
++ _tmp5_ = (GtkMessageDialog*) gtk_message_dialog_new ((GtkWindow*) _tmp3_, GTK_DIALOG_DESTROY_WITH_PARENT, GTK_MESSAGE_QUESTION, GTK_BUTTONS_YES_NO, "%s", _tmp4_);
+ g_object_ref_sink (_tmp5_);
+ dialog = _tmp5_;
+ _tmp6_ = dialog;
+@@ -2721,7 +2721,7 @@ void xnp_application_open_settings_dialo
+ e = _inner_error_;
+ _inner_error_ = NULL;
+ _tmp0_ = _ ("Unable to open the settings dialog");
+- _tmp1_ = (GtkMessageDialog*) gtk_message_dialog_new (NULL, GTK_DIALOG_DESTROY_WITH_PARENT, GTK_MESSAGE_ERROR, GTK_BUTTONS_CLOSE, _tmp0_);
++ _tmp1_ = (GtkMessageDialog*) gtk_message_dialog_new (NULL, GTK_DIALOG_DESTROY_WITH_PARENT, GTK_MESSAGE_ERROR, GTK_BUTTONS_CLOSE, "%s", _tmp0_);
+ g_object_ref_sink (_tmp1_);
+ error_dialog = _tmp1_;
+ _tmp2_ = error_dialog;
+--- a/lib/window.c
++++ b/lib/window.c
+@@ -3542,7 +3542,7 @@ void xnp_window_delete_note (XnpWindow*
+ GtkMessageDialog* _tmp13_;
+ gint _tmp14_;
+ _tmp9_ = _ ("Are you sure you want to delete this note?");
+- _tmp10_ = (GtkMessageDialog*) gtk_message_dialog_new ((GtkWindow*) self, GTK_DIALOG_DESTROY_WITH_PARENT, GTK_MESSAGE_QUESTION, GTK_BUTTONS_YES_NO, _tmp9_);
++ _tmp10_ = (GtkMessageDialog*) gtk_message_dialog_new ((GtkWindow*) self, GTK_DIALOG_DESTROY_WITH_PARENT, GTK_MESSAGE_QUESTION, GTK_BUTTONS_YES_NO, "%s", _tmp9_);
+ g_object_ref_sink (_tmp10_);
+ dialog = _tmp10_;
+ _tmp11_ = dialog;
diff --git a/external/meta-openembedded/meta-xfce/recipes-panel-plugins/notes/xfce4-notes-plugin_1.8.1.bb b/external/meta-openembedded/meta-xfce/recipes-panel-plugins/notes/xfce4-notes-plugin_1.8.1.bb
new file mode 100644
index 00000000..fcf98c18
--- /dev/null
+++ b/external/meta-openembedded/meta-xfce/recipes-panel-plugins/notes/xfce4-notes-plugin_1.8.1.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Notes plugin for the Xfce Panel"
+HOMEPAGE = "http://goodies.xfce.org/projects/panel-plugins/xfce4-notes-plugin"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+
+inherit xfce-panel-plugin
+
+DEPENDS += "gtk+ libxfce4ui xfce4-panel xfconf libunique"
+
+SRC_URI += " \
+ file://0001-main-status-icon.c-remove-deprecated-g_type_init.patch \
+ file://01_fix_format-string.patch \
+"
+SRC_URI[md5sum] = "31cb9520b01512a94344770b4befdb3b"
+SRC_URI[sha256sum] = "07a4c3e71431c24f97d2e270452dd0fa51ff0bdb6219a13a20d0bfa8d9de54b2"
+
+FILES_${PN} += "${libdir}/xfce4/panel-plugins/*.so.*"
+
+# *.so are required for plugin detection
+INSANE_SKIP_${PN} = "dev-so"