summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-xfce/recipes-xfce/xfce4-panel
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/meta-openembedded/meta-xfce/recipes-xfce/xfce4-panel
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/meta-openembedded/meta-xfce/recipes-xfce/xfce4-panel')
-rw-r--r--external/meta-openembedded/meta-xfce/recipes-xfce/xfce4-panel/files/0002-use-lxdm-to-replace-dm-tool.patch49
-rw-r--r--external/meta-openembedded/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.14.4.bb (renamed from external/meta-openembedded/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.13.3.bb)9
2 files changed, 54 insertions, 4 deletions
diff --git a/external/meta-openembedded/meta-xfce/recipes-xfce/xfce4-panel/files/0002-use-lxdm-to-replace-dm-tool.patch b/external/meta-openembedded/meta-xfce/recipes-xfce/xfce4-panel/files/0002-use-lxdm-to-replace-dm-tool.patch
new file mode 100644
index 00000000..b06e26e9
--- /dev/null
+++ b/external/meta-openembedded/meta-xfce/recipes-xfce/xfce4-panel/files/0002-use-lxdm-to-replace-dm-tool.patch
@@ -0,0 +1,49 @@
+From b80108f01b1425427f98341168ea44c4b1a5a2cf Mon Sep 17 00:00:00 2001
+From: Hongxu Jia <hongxu.jia@windriver.com>
+Date: Fri, 28 Jun 2019 16:02:13 +0800
+Subject: [PATCH] use lxdm to replace dm-tool
+
+OE does not support lightdm but lxdm,
+so use lxdm to replace dm-tool
+
+Upstream-Status: Inappropriate [oe specific]
+
+Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
+---
+ plugins/actions/actions.c | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/plugins/actions/actions.c b/plugins/actions/actions.c
+index 474798e..63eb41d 100644
+--- a/plugins/actions/actions.c
++++ b/plugins/actions/actions.c
+@@ -905,12 +905,12 @@ actions_plugin_actions_allowed (void)
+ GError *error = NULL;
+
+ /* check for commands we use */
+- path = g_find_program_in_path ("dm-tool");
++ path = g_find_program_in_path ("lxdm");
+ if (path != NULL)
+ PANEL_SET_FLAG (allow_mask, ACTION_TYPE_SWITCH_USER);
+ else
+ {
+- /* check for gdmflexiserver if dm-tool is not present */
++ /* check for gdmflexiserver if lxdm is not present */
+ g_free (path);
+ path = g_find_program_in_path ("gdmflexiserver");
+ if (path != NULL)
+@@ -1027,9 +1027,9 @@ actions_plugin_action_activate (GtkWidget *widget,
+ break;
+
+ case ACTION_TYPE_SWITCH_USER:
+- path = g_find_program_in_path ("dm-tool");
++ path = g_find_program_in_path ("lxdm");
+ if (path != NULL)
+- succeed = g_spawn_command_line_async ("dm-tool switch-to-greeter", &error);
++ succeed = g_spawn_command_line_async ("lxdm -c USER_SWITCH", &error);
+ else
+ succeed = g_spawn_command_line_async ("gdmflexiserver", &error);
+ g_free (path);
+--
+2.8.1
+
diff --git a/external/meta-openembedded/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.13.3.bb b/external/meta-openembedded/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.14.4.bb
index f1abf667..73cb82a1 100644
--- a/external/meta-openembedded/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.13.3.bb
+++ b/external/meta-openembedded/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.14.4.bb
@@ -2,16 +2,17 @@ SUMMARY = "Xfce4 Panel"
SECTION = "x11"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=26a8bd75d8f8498bdbbe64a27791d4ee"
-DEPENDS = "libxfce4util garcon libxfce4ui xfconf exo gtk+ gtk+3 dbus cairo virtual/libx11 libxml2 libwnck3 vala-native"
+DEPENDS = "garcon exo gtk+3 cairo virtual/libx11 libxml2 libwnck3 vala-native"
-inherit xfce gtk-doc gobject-introspection distro_features_check gtk-icon-cache remove-libtool
+inherit xfce gtk-doc gobject-introspection features_check remove-libtool mime-xdg
REQUIRED_DISTRO_FEATURES = "x11"
-SRC_URI[md5sum] = "0ccb448e3792949eb0ae9db8dc22789b"
-SRC_URI[sha256sum] = "b467feb7ee9797ad12f56a152570e42a96b94ad63580d45536aabee282440ce8"
+SRC_URI[md5sum] = "76efdbf7fb461f3058919c1309da67ca"
+SRC_URI[sha256sum] = "8e5ea79412ba84cfada897ff309cbe2cd4aca16b9bd4f93df060229528576fd5"
SRC_URI += " \
file://0001-windowmenu-do-not-display-desktop-icon-when-no-windo.patch \
+ file://0002-use-lxdm-to-replace-dm-tool.patch \
"
python populate_packages_prepend() {