summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-connectivity/python-thrift/python-thrift_0.13.0.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/meta-python2/recipes-connectivity/python-thrift/python-thrift_0.13.0.bb
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/meta-python2/recipes-connectivity/python-thrift/python-thrift_0.13.0.bb')
-rw-r--r--external/meta-python2/recipes-connectivity/python-thrift/python-thrift_0.13.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-connectivity/python-thrift/python-thrift_0.13.0.bb b/external/meta-python2/recipes-connectivity/python-thrift/python-thrift_0.13.0.bb
new file mode 100644
index 00000000..2d51619d
--- /dev/null
+++ b/external/meta-python2/recipes-connectivity/python-thrift/python-thrift_0.13.0.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Python bindings for the Apache Thrift RPC system"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=e95cd2f17c70d3180a2b361332319fe0"
+
+SRC_URI[md5sum] = "c3bc8d9a910d2c9ce26f2ad1f7c96762"
+SRC_URI[sha256sum] = "9af1c86bf73433afc6010ed376a6c6aca2b54099cc0d61895f640870a9ae7d89"
+
+inherit pypi setuptools
+
+# Use different filename to prevent conflicts with thrift itself
+PYPI_SRC_URI_append = ";downloadfilename=${BP}.${PYPI_PACKAGE_EXT}"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-stringold \
+ ${PYTHON_PN}-threading \
+"