summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-automat_0.8.0.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/meta-python2/recipes-devtools/python/python-automat_0.8.0.bb
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-automat_0.8.0.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-automat_0.8.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-automat_0.8.0.bb b/external/meta-python2/recipes-devtools/python/python-automat_0.8.0.bb
new file mode 100644
index 00000000..404fa583
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-automat_0.8.0.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Self-service finite-state machines for the programmer on the go"
+DESCRIPTION = "Automat is a library for concise, idiomatic Python expression \
+of finite-state automata (particularly deterministic finite-state transducers)."
+HOMEPAGE = "https://github.com/glyph/Automat"
+SECTION = "devel/python"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4ad213bcca81688e94593e5f60c87477"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/python-automat:"
+
+SRC_URI[md5sum] = "47e980a48201a1dabe37fa11f0187013"
+SRC_URI[sha256sum] = "269a09dfb063a3b078983f4976d83f0a0d3e6e7aaf8e27d8df1095e09dc4a484"
+
+SRC_URI_append = " \
+ file://0001-setup.py-remove-the-dependency-on-m2r.patch \
+"
+
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+
+PYPI_PACKAGE = "Automat"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-attrs \
+ ${PYTHON_PN}-six \
+"