summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-bcrypt_3.1.7.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/meta-python2/recipes-devtools/python/python-bcrypt_3.1.7.bb
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-bcrypt_3.1.7.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-bcrypt_3.1.7.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-bcrypt_3.1.7.bb b/external/meta-python2/recipes-devtools/python/python-bcrypt_3.1.7.bb
new file mode 100644
index 00000000..4e473dd8
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-bcrypt_3.1.7.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Modern password hashing for your software and your servers."
+DESCRIPTION = "Good password hashing for your software and your servers"
+HOMEPAGE = "https://github.com/pyca/bcrypt/"
+SECTION = "devel/python"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8f7bb094c7232b058c7e9f2e431f389c"
+
+SRC_URI[md5sum] = "5d6f93b575ce52470af37a8e7dce76fe"
+SRC_URI[sha256sum] = "0b0069c752ec14172c5f78208f1863d7ad6755a6fae6fe76ec2c80d13be41e42"
+
+DEPENDS += "${PYTHON_PN}-cffi-native"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN}_class-target += "\
+ ${PYTHON_PN}-cffi \
+ ${PYTHON_PN}-ctypes \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-subprocess \
+"