summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-configargparse_0.15.1.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/meta-python2/recipes-devtools/python/python-configargparse_0.15.1.bb
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-configargparse_0.15.1.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-configargparse_0.15.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-configargparse_0.15.1.bb b/external/meta-python2/recipes-devtools/python/python-configargparse_0.15.1.bb
new file mode 100644
index 00000000..e107ecd4
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-configargparse_0.15.1.bb
@@ -0,0 +1,26 @@
+
+SUMMARY = "A drop-in replacement for argparse with options to be set via config files or env variables."
+DESCRIPTION = "A drop-in replacement for argparse that allows options to also be set via \
+config files and/or environment variables."
+HOMEPAGE = "https://github.com/bw2/ConfigArgParse"
+SECTION = "devel/python"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=da746463714cc35999ed9a42339f2943"
+
+SRC_URI[md5sum] = "aba15b7973b7a70bea86fd69289f8fe3"
+SRC_URI[sha256sum] = "baaf0fd2c1c108d007f402dab5481ac5f12d77d034825bf5a27f8224757bd0ac"
+
+PYPI_PACKAGE = "ConfigArgParse"
+
+inherit pypi setuptools
+
+PACKAGECONFIG ?= "yaml"
+PACKAGECONFIG[yaml] = ",,,${PYTHON_PN}-pyyaml"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-shell \
+"
+
+BBCLASSEXTEND = "native nativesdk"