summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-engineio_3.11.2.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/meta-python2/recipes-devtools/python/python-engineio_3.11.2.bb
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-engineio_3.11.2.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-engineio_3.11.2.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-engineio_3.11.2.bb b/external/meta-python2/recipes-devtools/python/python-engineio_3.11.2.bb
new file mode 100644
index 00000000..09188b4b
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-engineio_3.11.2.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Engine.IO server"
+DESCRIPTION = "Python implementation of the Engine.IO realtime client and server."
+HOMEPAGE = "https://github.com/miguelgrinberg/python-engineio/"
+SECTION = "devel/python"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=42d0a9e728978f0eeb759c3be91536b8"
+
+SRC_URI[md5sum] = "13345452be25c3b63d041f8f89e662d1"
+SRC_URI[sha256sum] = "47ae4a9b3b4f2e8a68929f37a518338838e119f24c9a9121af92c49f8bea55c3"
+
+PYPI_PACKAGE = "python-engineio"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN}_append_class-target = "\
+ ${PYTHON_PN}-compression \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-logging \
+"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-six \
+"