summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-flask-babel_0.12.2.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/meta-python2/recipes-devtools/python/python-flask-babel_0.12.2.bb
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-flask-babel_0.12.2.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-flask-babel_0.12.2.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-flask-babel_0.12.2.bb b/external/meta-python2/recipes-devtools/python/python-flask-babel_0.12.2.bb
new file mode 100644
index 00000000..b40a676f
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-flask-babel_0.12.2.bb
@@ -0,0 +1,21 @@
+SUMMARY = "i18n and l10n support for Flask based on babel and pytz"
+DESCRIPTION = "Implements i18n and l10n support for Flask. This is based on \
+the Python babel module as well as pytz both of which are installed \
+automatically for you if you install this library."
+HOMEPAGE = "http://github.com/python-babel/flask-babel"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=51917f3e8e858f5ae295a7d0e2eb3cc9"
+
+SRC_URI[md5sum] = "fcf2f360ff279d3133e40974804efd72"
+SRC_URI[sha256sum] = "316ad183e42003f3922957fa643d0a1e8e34a0f0301a88c3a8f605bc37ba5c86"
+
+PYPI_PACKAGE = "Flask-Babel"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-babel \
+ ${PYTHON_PN}-flask \
+ ${PYTHON_PN}-speaklater \
+ "