summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-flask_1.1.1.bb
diff options
context:
space:
mode:
authortakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
committertakeshi_hoshina <takeshi_hoshina@mail.toyota.co.jp>2020-11-02 11:07:33 +0900
commit1c7d6584a7811b7785ae5c1e378f14b5ba0971cf (patch)
treecd70a267a5ef105ba32f200aa088e281fbd85747 /external/meta-python2/recipes-devtools/python/python-flask_1.1.1.bb
parent4204309872da5cb401cbb2729d9e2d4869a87f42 (diff)
recipes
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-flask_1.1.1.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-flask_1.1.1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-flask_1.1.1.bb b/external/meta-python2/recipes-devtools/python/python-flask_1.1.1.bb
new file mode 100644
index 00000000..432b944d
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-flask_1.1.1.bb
@@ -0,0 +1,23 @@
+SUMMARY = "A microframework based on Werkzeug, Jinja2 and good intentions"
+DESCRIPTION = "\
+Flask is a microframework for Python based on Werkzeug, Jinja 2 and good \
+intentions. And before you ask: It’s BSD licensed!"
+HOMEPAGE = "https://github.com/mitsuhiko/flask/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=ffeffa59c90c9c4a033c7574f8f3fb75"
+
+SRC_URI[md5sum] = "0e3ed44ece1c489ed835d1b7047e349c"
+SRC_URI[sha256sum] = "13f9f196f330c7c2c5d7a5cf91af894110ca0215ac051b5844701f2bfd934d52"
+
+CLEANBROKEN = "1"
+
+PYPI_PACKAGE = "Flask"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-click \
+ ${PYTHON_PN}-itsdangerous \
+ ${PYTHON_PN}-jinja2 \
+ ${PYTHON_PN}-werkzeug \
+ "